summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoen2016-06-23 20:15:15 +0000
committerLoen2016-06-23 20:15:15 +0000
commit1791b7c8c75bfd246382f199da221514cdaae3ed (patch)
treed2a80278dfd2159b89623af21cf1755d6abb1a27
parenteb5b4446c28bd52ae3b9b98d476b1dd0bb3d85b5 (diff)
downloadaur-1791b7c8c75bfd246382f199da221514cdaae3ed.tar.gz
First Loen commit
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6fb2400bc65..fc2520924411 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-libsass
pkgdesc = Python binding for libsass CSS compiler
- pkgver = 0.7.0
+ pkgver = 0.11.1
pkgrel = 1
url = http://dahlia.kr/libsass-python/
arch = any
- license = LGPL
+ license = MIT
makedepends = libsass
+ makedepends = python2-pip
+ makedepends = python-pip
depends = python
- source = https://pypi.python.org/packages/source/l/libsass/libsass-0.7.0.tar.gz
- md5sums = 809e4f66bd54eeb46342d7462ce961e6
+ source = https://github.com/dahlia/libsass-python/releases/download/0.11.1/libsass-0.11.1.tar.gz
+ sha256sums = f060d7dab825942ca7f86d0c4adadf7d731a2e30f9bce6e4f010ad7d32adbf06
pkgname = python-libsass
diff --git a/PKGBUILD b/PKGBUILD
index 6941e2a09b36..e51f5d6ad60c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-#Contributor: Scott Lawrence <bytbox@gmail.com>
-pkgname=python-libsass
-pkgver=0.7.0
+# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Contributor: Scott Lawrence <bytbox@gmail.com>
+pkgname='python-libsass'
+pkgver='0.11.1'
pkgrel=1
pkgdesc="Python binding for libsass CSS compiler"
-arch=(any)
-url="http://dahlia.kr/libsass-python/"
-depends=(python)
-makedepends=(libsass)
-source=(https://pypi.python.org/packages/source/l/libsass/libsass-${pkgver}.tar.gz)
-license=('LGPL')
-
-build() {
- cd $srcdir/libsass-$pkgver
- python setup.py build
-}
+arch=('any')
+url='http://dahlia.kr/libsass-python/'
+depends=('python')
+makedepends=('libsass' 'python2-pip' 'python-pip')
+source=('https://github.com/dahlia/libsass-python/releases/download/0.11.1/libsass-0.11.1.tar.gz')
+license=('MIT')
+sha256sums=('f060d7dab825942ca7f86d0c4adadf7d731a2e30f9bce6e4f010ad7d32adbf06')
package() {
- cd $srcdir/libsass-$pkgver
- python setup.py install --root=$pkgdir
+ echo Installation may be a bit slow, please wait
+ cd ${srcdir}/libsass-${pkgver}
+ pip install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+ pip2 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+
}
-md5sums=('809e4f66bd54eeb46342d7462ce961e6')