summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-08-28 10:30:08 +0800
committerlilac2020-08-28 10:30:08 +0800
commit7897db89695b605a7ac88bd96b37c8f33ca9e66b (patch)
tree781cc87d5fea12459b342b59d1ee065c6ab027b3
parentf2b6a29ab695174a2bd21d743bc63970e04ca6d3 (diff)
downloadaur-7897db89695b605a7ac88bd96b37c8f33ca9e66b.tar.gz
[lilac] updated to 0.20.1-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9c5574e2e84..8da6c28d97d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python-libsass
pkgdesc = Sass for Python: A straightforward binding of libsass for Python.
- pkgver = 0.19.4
- pkgrel = 2
+ pkgver = 0.20.1
+ pkgrel = 1
url = https://sass.github.io/libsass-python/
arch = x86_64
- license = MIT
+ license = MIT License
makedepends = gcc
- depends = python
depends = python-six
depends = libsass
depends = python-setuptools
provides = sassc
- source = https://files.pythonhosted.org/packages/source/l/libsass/libsass-0.19.4.tar.gz
- md5sums = 33247c8777f30b03d02163e8fd86b214
+ source = https://files.pythonhosted.org/packages/source/l/libsass/libsass-0.20.1.tar.gz
+ sha256sums = e0e60836eccbf2d9e24ec978a805cd6642fa92515fbd95e3493fee276af76f8a
pkgname = python-libsass
diff --git a/PKGBUILD b/PKGBUILD
index 47f92f4085c9..85f463d83f41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-_pkgname=libsass
+_name=libsass
pkgname=python-libsass
-pkgver=0.19.4
-pkgrel=2
+pkgver=0.20.1
+pkgrel=1
pkgdesc="Sass for Python: A straightforward binding of libsass for Python."
arch=('x86_64')
url="https://sass.github.io/libsass-python/"
-license=('MIT')
-depends=('python' 'python-six' 'libsass' 'python-setuptools')
-_name=${pkgname#python-}
+license=('MIT License')
+depends=('python-six' 'libsass' 'python-setuptools')
makedepends=('gcc')
provides=('sassc')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_pkgname}-${pkgver}.tar.gz")
-md5sums=('33247c8777f30b03d02163e8fd86b214')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/libsass-0.20.1.tar.gz")
+sha256sums=('e0e60836eccbf2d9e24ec978a805cd6642fa92515fbd95e3493fee276af76f8a')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py build
+ cd "$srcdir/libsass-0.20.1"
+ python3 setup.py build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir/libsass-0.20.1"
+ python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+
+ # make sure we don't install annoying files
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rf "$pkgdir/$_site_packages/tests/"
}
-# vim:set sw=2 et: