summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Asuncion2016-12-17 08:58:08 -0800
committerJeremy Asuncion2016-12-17 08:58:08 -0800
commit4d0436579e0591b38dd892f7fe753ae2a824ba7e (patch)
treee2fde7a55e5412c862b93d4333ea8d0eb394880a
downloadaur-4d0436579e0591b38dd892f7fe753ae2a824ba7e.tar.gz
Added PKGBUILD for aur
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f091a71ddce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-license
+ pkgdesc = A command line app that fetches opensource licenses.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/codemonkey800/python-license
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-click-completion
+ depends = python-click-didyoumean
+ depends = python-requests
+ depends = python-requests-cache
+ source = https://github.com/codemonkey800/python-license/archive/0.1.0.tar.gz
+ md5sums = d5eded862d8f6254dc9445e1fece1436
+
+pkgname = python-license
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa73bd6a618b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# vim: set ft=sh ts=4 sw=4 sts=4 et:
+# Maintainer: Jeremy Asuncion <jeremyasuncion808@gmail.com>
+
+pkgname=python-license
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A command line app that fetches opensource licenses.'
+arch=(any)
+url='https://github.com/codemonkey800/python-license'
+license=(MIT)
+depends=(
+ python
+ python-click
+ python-click-completion
+ python-click-didyoumean
+ python-requests
+ python-requests-cache
+)
+makedepends=(python-setuptools)
+source=("https://github.com/codemonkey800/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=(d5eded862d8f6254dc9445e1fece1436)
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install -O1 --skip-build --prefix=/usr --root="${pkgdir}"
+}
+