summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormxmehl2019-08-08 16:37:42 +0200
committermxmehl2019-08-08 16:37:42 +0200
commita9571451c8472a59ce0553d38b2251109de68d7a (patch)
treec165e8d41022df0c6859e0799e842a868d5e0c7b
downloadaur-a9571451c8472a59ce0553d38b2251109de68d7a.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0618fafc552
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-license-expression
+ pkgdesc = Utility library to parse, normalize and compare License expressions for Python using a boolean logic engine
+ pkgver = 0.999
+ pkgrel = 1
+ url = https://github.com/nexB/license-expression
+ arch = any
+ license = Apache-2.0
+ checkdepends = python-tox
+ makedepends = python-setuptools
+ makedepends = python-boolean.py
+ depends = python
+ source = python-license-expression-0.999.tar.gz::https://github.com/nexB/license-expression/archive/v0.999.tar.gz
+ sha256sums = 5c166fffbb81ee78b629b4937758974b86b43536887bdf6cd1cd0962042e5cef
+
+pkgname = python-license-expression
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..baf1cc3d2553
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Max Mehl <aur at mehl dot mx>
+# SPDX-FileCopyrightText: 2019 Max Mehl
+# SPDX-License-Identifier: CC0-1.0
+
+pkgname='python-license-expression'
+pkgver=0.999
+pkgrel=1
+pkgdesc='Utility library to parse, normalize and compare License expressions for Python using a boolean logic engine'
+arch=('any')
+url='https://github.com/nexB/license-expression'
+license=('Apache-2.0')
+depends=('python')
+makedepends=('python-setuptools' 'python-boolean.py')
+checkdepends=('python-tox')
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/nexB/license-expression/archive/v${pkgver}.tar.gz"
+)
+sha256sums=('5c166fffbb81ee78b629b4937758974b86b43536887bdf6cd1cd0962042e5cef')
+
+check() {
+ cd "$srcdir/license-expression-$pkgver"
+ python setup.py test
+}
+
+package() {
+ cd "$srcdir/license-expression-$pkgver"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim: ts=2 sw=2 et: