summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-09-25 16:06:43 -0400
committerAndrew Sun2019-09-25 16:06:43 -0400
commite8ecba24188460e5a91264c9e80bb73dc1b05a2b (patch)
tree968743382fb924732b4c84c5a0d99ab900fa49fe
parent5e98ec76ec13e1978d1ae0fc20cfc0bbcb3ef514 (diff)
downloadaur-e8ecba24188460e5a91264c9e80bb73dc1b05a2b.tar.gz
update to 0.22.6, remove python2 version
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD49
2 files changed, 32 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ea25da3d85f..9a9eef10d420 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,17 @@
-# Generated by mksrcinfo v8
-# Sat Aug 20 08:45:53 UTC 2016
pkgbase = python-lifelines
pkgdesc = Survival analysis in Python
- pkgver = 0.8.0
+ pkgver = 0.22.6
pkgrel = 1
- url = http://lifelines.readthedocs.org
- arch = i686
- arch = x86_64
- license = custom
+ url = https://github.com/CamDavidsonPilon/lifelines
+ arch = any
+ license = MIT
makedepends = python-setuptools
- makedepends = python2-setuptools
- options = !buildflags
- source = https://github.com/CamDavidsonPilon/lifelines/archive/v0.8.0.tar.gz
- md5sums = 62d37d58cfd489307dbb9b9edf6114a1
-
-pkgname = python-lifelines
- depends = python-scipy
+ depends = python-autograd-gamma
+ depends = python-matplotlib
depends = python-pandas
+ options = !emptydirs
+ source = lifelines-0.22.6.tar.gz::https://github.com/CamDavidsonPilon/lifelines/archive/v0.22.6.tar.gz
+ sha256sums = ccacd8a316ef8fdcfa7c022d28304d33734b8d24dc709c8c3862b1eca4416aad
-pkgname = python2-lifelines
- depends = python2-scipy
- depends = python2-pandas
+pkgname = python-lifelines
diff --git a/PKGBUILD b/PKGBUILD
index 2b639f16220c..3ac5b9fef558 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,31 @@
-pkgbase=python-lifelines
-pkgname=('python-lifelines' 'python2-lifelines')
-pkgver=0.8.0
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+
+_pkgname=lifelines
+pkgname=python-lifelines
+pkgver=0.22.6
pkgrel=1
pkgdesc="Survival analysis in Python"
-url="http://lifelines.readthedocs.org"
-arch=('i686' 'x86_64')
-license=('custom')
-makedepends=('python-setuptools' 'python2-setuptools')
-options=('!buildflags')
-source=("https://github.com/CamDavidsonPilon/lifelines/archive/v${pkgver}.tar.gz")
-md5sums=('62d37d58cfd489307dbb9b9edf6114a1')
+url="https://github.com/CamDavidsonPilon/lifelines"
+arch=('any')
+license=('MIT')
+depends=('python-autograd-gamma' 'python-matplotlib' 'python-pandas')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/v${pkgver}.tar.gz")
+sha256sums=('ccacd8a316ef8fdcfa7c022d28304d33734b8d24dc709c8c3862b1eca4416aad')
build() {
- cp -r "${srcdir}"/lifelines-$pkgver "${srcdir}"/lifelines-$pkgver-py2
-
- cd "${srcdir}"/lifelines-$pkgver
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
-
- cd "${srcdir}"/lifelines-$pkgver-py2
- python2 setup.py build
}
-package_python-lifelines() {
- depends=('python-scipy' 'python-pandas')
-
- cd "${srcdir}"/lifelines-$pkgver
- python setup.py install --root="${pkgdir}"
-}
-
-package_python2-lifelines() {
- depends=('python2-scipy' 'python2-pandas')
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "${srcdir}"/lifelines-$pkgver-py2
- python2 setup.py install --root="${pkgdir}"
+ # Move Files
+ mkdir -p ${pkgdir}/usr/share/doc/${pkgname}
+ _ver=$(python -c "import platform; print(platform.python_version())")
+ mv ${pkgdir}/usr/lib/python${_ver%.*}/site-packages/{LICENSE,README.md,MANIFEST.in} ${pkgdir}/usr/share/doc/${pkgname}
}