summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-02-08 14:42:10 -0500
committerGuillaume Horel2022-02-08 14:42:10 -0500
commit13cdd4fd6ccff119d0882b20664303bf70fac2a7 (patch)
treee05dedcbba3cb6b253f859bdbda9cb3e87e3d1ad
parent9bdbb36c89396ce0e21a0f24f90cf1bb889f288d (diff)
downloadaur-13cdd4fd6ccff119d0882b20664303bf70fac2a7.tar.gz
bump to 3.4.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--line_profiler.patch24
3 files changed, 6 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74d8e0f40680..749378c3951b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-lineprofiler
pkgdesc = Line-by-line profiler
- pkgver = 3.3.1
+ pkgver = 3.4.0
pkgrel = 1
url = https://pypi.python.org/pypi/line_profiler
arch = x86_64
@@ -8,9 +8,9 @@ pkgbase = python-lineprofiler
makedepends = cython
depends = python-setuptools
depends = ipython
- source = line_profiler-3.3.1.tar.gz::https://github.com/pyutils/line_profiler/archive/3.3.1.tar.gz
+ source = line_profiler-3.4.0.tar.gz::https://github.com/pyutils/line_profiler/archive/v3.4.0.tar.gz
source = cython.patch
- sha256sums = 6c0caf8fe2241a81d23b4a937e6a497adaae1848a68d175863f2143c14ccfe7a
+ sha256sums = cc89c869984544f14b4f44ee9968a3cff254e68dc54cea385c22bd50938097b2
sha256sums = 3acc85c3eebe59d94edfa1624e68d06d3f4fad342d5380606f69c566d93c8131
pkgname = python-lineprofiler
diff --git a/PKGBUILD b/PKGBUILD
index f2c44613a879..10c715b86a3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Sebastien Binet <binet@lblbox>
pkgname=python-lineprofiler
_pkgname=line_profiler
-pkgver=3.3.1
+pkgver=3.4.0
pkgrel=1
pkgdesc="Line-by-line profiler"
url="https://pypi.python.org/pypi/line_profiler"
@@ -12,10 +12,10 @@ arch=('x86_64')
license=('BSD')
depends=('python-setuptools' 'ipython')
makedepends=('cython')
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/pyutils/line_profiler/archive/$pkgver.tar.gz"
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/pyutils/line_profiler/archive/v$pkgver.tar.gz"
"cython.patch")
-sha256sums=('6c0caf8fe2241a81d23b4a937e6a497adaae1848a68d175863f2143c14ccfe7a'
+sha256sums=('cc89c869984544f14b4f44ee9968a3cff254e68dc54cea385c22bd50938097b2'
'3acc85c3eebe59d94edfa1624e68d06d3f4fad342d5380606f69c566d93c8131')
prepare() {
diff --git a/line_profiler.patch b/line_profiler.patch
deleted file mode 100644
index 803c7579bdd7..000000000000
--- a/line_profiler.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -ruN line_profiler-2.1.2.orig/kernprof.py line_profiler-2.1.2/kernprof.py
---- line_profiler-2.1.2.orig/kernprof.py 2018-08-30 14:14:52.722665861 +0200
-+++ line_profiler-2.1.2/kernprof.py 2018-08-30 14:18:42.516791010 +0200
-@@ -102,6 +102,8 @@
- self.enable_by_count()
- try:
- item = g.send(input)
-+ except StopIteration:
-+ return
- finally:
- self.disable_by_count()
- input = (yield item)
-diff -ruN line_profiler-2.1.2.orig/line_profiler.py line_profiler-2.1.2/line_profiler.py
---- line_profiler-2.1.2.orig/line_profiler.py 2018-08-30 14:14:52.722665861 +0200
-+++ line_profiler-2.1.2/line_profiler.py 2018-08-30 14:19:11.210222041 +0200
-@@ -100,6 +100,8 @@
- self.enable_by_count()
- try:
- item = g.send(input)
-+ except StopIteration:
-+ return
- finally:
- self.disable_by_count()
- input = (yield item)