summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2023-05-08 10:25:03 -0400
committerGuillaume Horel2023-05-08 10:25:03 -0400
commit1ff7babcf53ec1644b39cad5c1581eb892132ec5 (patch)
tree69425cc3aeb27d8b2d673c1da2ff7a18ce482c10
parent30b10ea0134778371cdca4a9b26722dbe8a3bf44 (diff)
downloadaur-1ff7babcf53ec1644b39cad5c1581eb892132ec5.tar.gz
bump to 4.0.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1694f991f15..2db7f5a04638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = python-lineprofiler
pkgdesc = Line-by-line profiler
- pkgver = 4.0.2
+ pkgver = 4.0.3
pkgrel = 1
url = https://pypi.python.org/pypi/line_profiler
arch = x86_64
license = BSD
checkdepends = python-pytest
checkdepends = python-ubelt
- makedepends = cython3
+ makedepends = cython
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
depends = python-setuptools
depends = ipython
- source = line_profiler-4.0.2.tar.gz::https://github.com/pyutils/line_profiler/archive/v4.0.2.tar.gz
- sha256sums = 4b10543d250ad900c2ab38d90d5e51aa7e645cd1e94842cda76706e486ba02b7
+ source = line_profiler-4.0.3.tar.gz::https://github.com/pyutils/line_profiler/archive/v4.0.3.tar.gz
+ sha256sums = 81df8a475048d1c8c905cb5a4530c44f2581b6c78c2f64301a65fe2d4a3028d3
pkgname = python-lineprofiler
diff --git a/PKGBUILD b/PKGBUILD
index a961d3ed00bd..8c16a83a1ef0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,32 +4,32 @@
# Contributor: Sebastien Binet <binet@lblbox>
pkgname=python-lineprofiler
_pkgname=line_profiler
-pkgver=4.0.2
+pkgver=4.0.3
pkgrel=1
pkgdesc="Line-by-line profiler"
url="https://pypi.python.org/pypi/line_profiler"
arch=('x86_64')
license=('BSD')
depends=('python-setuptools' 'ipython')
-makedepends=('cython3' 'python-build' 'python-installer' 'python-wheel')
+makedepends=('cython' 'python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest' 'python-ubelt')
source=("$_pkgname-$pkgver.tar.gz::https://github.com/pyutils/line_profiler/archive/v$pkgver.tar.gz")
-sha256sums=('4b10543d250ad900c2ab38d90d5e51aa7e645cd1e94842cda76706e486ba02b7')
+sha256sums=('81df8a475048d1c8c905cb5a4530c44f2581b6c78c2f64301a65fe2d4a3028d3')
build() {
cd "$_pkgname-$pkgver"
python -m build --wheel --no-isolation
}
-#check() {
- #local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- #cd "$_pkgname-${pkgver}"
- #python -m installer --destdir=test_dir dist/*.whl
- #export PYTHONPATH="test_dir/$_site_packages:$PYTHONPATH"
- #export PATH="${srcdir}/$_pkgname-${pkgver}/test_dir/usr/bin:$PATH"
- #pytest tests
-#}
+check() {
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ cd "$_pkgname-${pkgver}"
+ python -m installer --destdir=test_dir dist/*.whl
+ export PYTHONPATH="${srcdir}/$_pkgname-${pkgver}/test_dir/$_site_packages"
+ export PATH="${srcdir}/$_pkgname-${pkgver}/test_dir/usr/bin:$PATH"
+ ./run_tests.py
+}
package() {
cd "line_profiler-${pkgver}"