summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2023-01-17 14:21:48 -0500
committerGuillaume Horel2023-01-17 14:21:48 -0500
commit3aa5dfe8982e34cd48de022b7a8d4ea24bb2b34f (patch)
treeaee391d8b9cb25a9a71f685e7545c1df2c8ec6a3
parent09b2ed75c98654862e735ea988b720675e6956b7 (diff)
downloadaur-3aa5dfe8982e34cd48de022b7a8d4ea24bb2b34f.tar.gz
remove unneeded patch
-rw-r--r--cython.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/cython.patch b/cython.patch
deleted file mode 100644
index 6b01f4b8e88f..000000000000
--- a/cython.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -urN line_profiler-3.3.1-orig/setup.py line_profiler-3.3.1/setup.py
---- line_profiler-3.3.1-orig/setup.py 2021-12-17 14:50:32.739504227 -0500
-+++ line_profiler-3.3.1/setup.py 2021-12-17 14:50:41.046174297 -0500
-@@ -215,13 +215,16 @@
-
-
- if __name__ == '__main__':
-- if '--universal' in sys.argv:
-- # Dont use scikit-build for universal wheels
-- # if 'develop' in sys.argv:
-- sys.argv.remove('--universal')
-- from setuptools import setup # NOQA
-- else:
-- from skbuild import setup
-+ from setuptools import setup # NOQA
-+ from setuptools.extension import Extension
-+ from Cython.Build import cythonize
-+ extension = Extension('line_profiler._line_profiler',
-+ sources=["line_profiler/_line_profiler.pyx",
-+ 'line_profiler/timers.c',
-+ 'line_profiler/unset_trace.c'],
-+ depends=['python25.pxd'],
-+ extra_compile_args=["-DHAVE_GETTIMEOFDAY"])
-+ extension = cythonize([extension])
- setupkw = dict(
- name=NAME,
- version=VERSION,
-@@ -251,6 +254,7 @@
- 'Topic :: Software Development',
- ],
- # py_modules=find_packages(),
-+ ext_modules=extension,
- packages=list(find_packages()),
- py_modules=['kernprof', 'line_profiler'],
- entry_points={