summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Klimczak2018-09-30 17:40:46 +0200
committerMichael Klimczak2018-09-30 17:40:46 +0200
commit4f3c4c2033e8cfe3438bda18f01586ba983af918 (patch)
treec8fdca3065e08fa6145b5d1f62e9aa20045ab9a6
parentabbabd4bb4fb7454d9d94e680da0144156ff0261 (diff)
downloadaur-4f3c4c2033e8cfe3438bda18f01586ba983af918.tar.gz
added patch and modified PKGBUILD to fix issues with python 3.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--line_profiler.patch24
3 files changed, 38 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3f74bd9cdd6..227f48027006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-lineprofiler
pkgdesc = Line-by-line profiler
- pkgver = 2.1
- pkgrel = 2
+ pkgver = 2.1.2
+ pkgrel = 3
url = https://pypi.python.org/pypi/line_profiler
arch = i686
arch = x86_64
@@ -9,8 +9,10 @@ pkgbase = python-lineprofiler
makedepends = cython
depends = python-setuptools
depends = ipython
- source = python-lineprofiler-2.1.tar.gz::https://github.com/rkern/line_profiler/archive/2.1.tar.gz
- sha256sums = 5625157e76e1f70c237c7df07389b48028aa1b94ec630aaa5f094d5755bcaa76
+ source = https://files.pythonhosted.org/packages/14/fc/ecf4e238bb601ff829068e5a72cd1bd67b0ee0ae379db172eb6a0779c6b6/line_profiler-2.1.2.tar.gz
+ source = line_profiler.patch
+ md5sums = 141cb6996f0e3188ca05bfddcb403e36
+ md5sums = fd05a4246f3bb741bbf9b51ca3e14d34
pkgname = python-lineprofiler
diff --git a/PKGBUILD b/PKGBUILD
index 7c830fb6ceeb..dfd0f56fb1c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
# Contributor: lestb <tkhdlstfl dot l plus aur at gmail dot com>
# Contributor: Sebastien Binet <binet@lblbox>
pkgname=python-lineprofiler
-pkgver=2.1
-pkgrel=2
+pkgver=2.1.2
+pkgrel=3
pkgdesc="Line-by-line profiler"
url="https://pypi.python.org/pypi/line_profiler"
arch=('i686' 'x86_64')
license=('BSD')
depends=('python-setuptools' 'ipython')
makedepends=('cython')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/rkern/line_profiler/archive/$pkgver.tar.gz")
-sha256sums=('5625157e76e1f70c237c7df07389b48028aa1b94ec630aaa5f094d5755bcaa76')
+source=(https://files.pythonhosted.org/packages/14/fc/ecf4e238bb601ff829068e5a72cd1bd67b0ee0ae379db172eb6a0779c6b6/line_profiler-${pkgver}.tar.gz line_profiler.patch)
+md5sums=('141cb6996f0e3188ca05bfddcb403e36' 'fd05a4246f3bb741bbf9b51ca3e14d34')
build() {
+ cd "${srcdir}"
+ patch -s -p0 < line_profiler.patch
+
cd "${srcdir}/line_profiler-${pkgver}"
+ cython _line_profiler.pyx
python setup.py build
}
diff --git a/line_profiler.patch b/line_profiler.patch
new file mode 100644
index 000000000000..803c7579bdd7
--- /dev/null
+++ b/line_profiler.patch
@@ -0,0 +1,24 @@
+diff -ruN line_profiler-2.1.2.orig/kernprof.py line_profiler-2.1.2/kernprof.py
+--- line_profiler-2.1.2.orig/kernprof.py 2018-08-30 14:14:52.722665861 +0200
++++ line_profiler-2.1.2/kernprof.py 2018-08-30 14:18:42.516791010 +0200
+@@ -102,6 +102,8 @@
+ self.enable_by_count()
+ try:
+ item = g.send(input)
++ except StopIteration:
++ return
+ finally:
+ self.disable_by_count()
+ input = (yield item)
+diff -ruN line_profiler-2.1.2.orig/line_profiler.py line_profiler-2.1.2/line_profiler.py
+--- line_profiler-2.1.2.orig/line_profiler.py 2018-08-30 14:14:52.722665861 +0200
++++ line_profiler-2.1.2/line_profiler.py 2018-08-30 14:19:11.210222041 +0200
+@@ -100,6 +100,8 @@
+ self.enable_by_count()
+ try:
+ item = g.send(input)
++ except StopIteration:
++ return
+ finally:
+ self.disable_by_count()
+ input = (yield item)