summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-12-17 14:52:40 -0500
committerGuillaume Horel2021-12-17 14:52:40 -0500
commit9bdbb36c89396ce0e21a0f24f90cf1bb889f288d (patch)
tree15f16ee047164e715bd1b33c8021be65cb45162d
parentec601d5a80270167981d417e58a1d6c54f3462a3 (diff)
downloadaur-9bdbb36c89396ce0e21a0f24f90cf1bb889f288d.tar.gz
bump to 3.3.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--cython.patch64
3 files changed, 40 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 291a623aaf17..74d8e0f40680 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-lineprofiler
pkgdesc = Line-by-line profiler
- pkgver = 3.0.2
+ pkgver = 3.3.1
pkgrel = 1
url = https://pypi.python.org/pypi/line_profiler
arch = x86_64
@@ -8,10 +8,9 @@ pkgbase = python-lineprofiler
makedepends = cython
depends = python-setuptools
depends = ipython
- source = line_profiler-3.0.2.tar.gz::https://github.com/pyutils/line_profiler/archive/3.0.2.tar.gz
+ source = line_profiler-3.3.1.tar.gz::https://github.com/pyutils/line_profiler/archive/3.3.1.tar.gz
source = cython.patch
- sha256sums = 8eb9683b339083220adec19f391006435efb47ef63fc1200b965a88b48068f26
- sha256sums = e275bc6da60b49fa778d53a91acb8b9a866f80cf7dc2ff47b42c78e661b256c7
+ sha256sums = 6c0caf8fe2241a81d23b4a937e6a497adaae1848a68d175863f2143c14ccfe7a
+ sha256sums = 3acc85c3eebe59d94edfa1624e68d06d3f4fad342d5380606f69c566d93c8131
pkgname = python-lineprofiler
-
diff --git a/PKGBUILD b/PKGBUILD
index 82dc472940b7..f2c44613a879 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Guillaume HOrel <guillaume.horel@gmail.com>
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
# Contributor: Rich Li <rich at dranek com>
# Contributor: lestb <tkhdlstfl dot l plus aur at gmail dot com>
# Contributor: Sebastien Binet <binet@lblbox>
pkgname=python-lineprofiler
_pkgname=line_profiler
-pkgver=3.0.2
+pkgver=3.3.1
pkgrel=1
pkgdesc="Line-by-line profiler"
url="https://pypi.python.org/pypi/line_profiler"
@@ -15,8 +15,8 @@ makedepends=('cython')
source=("$_pkgname-$pkgver.tar.gz::https://github.com/pyutils/line_profiler/archive/$pkgver.tar.gz"
"cython.patch")
-sha256sums=('8eb9683b339083220adec19f391006435efb47ef63fc1200b965a88b48068f26'
- 'e275bc6da60b49fa778d53a91acb8b9a866f80cf7dc2ff47b42c78e661b256c7')
+sha256sums=('6c0caf8fe2241a81d23b4a937e6a497adaae1848a68d175863f2143c14ccfe7a'
+ '3acc85c3eebe59d94edfa1624e68d06d3f4fad342d5380606f69c566d93c8131')
prepare() {
cd "$_pkgname-$pkgver"
@@ -36,7 +36,7 @@ check() {
package() {
cd "line_profiler-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install --skip-build --prefix=/usr --root="${pkgdir}" --optimize=1
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 LICENSE{,_Python}.txt "${pkgdir}/usr/share/licenses/${pkgname}"
diff --git a/cython.patch b/cython.patch
index d94683e36a89..6b01f4b8e88f 100644
--- a/cython.patch
+++ b/cython.patch
@@ -1,37 +1,35 @@
---- a/setup.py 2020-01-12 15:51:13.000000000 -0500
-+++ b/setup.py 2021-01-12 22:54:31.181954242 -0500
-@@ -150,7 +150,7 @@
- return mb_tag
+diff -urN line_profiler-3.3.1-orig/setup.py line_profiler-3.3.1/setup.py
+--- line_profiler-3.3.1-orig/setup.py 2021-12-17 14:50:32.739504227 -0500
++++ line_profiler-3.3.1/setup.py 2021-12-17 14:50:41.046174297 -0500
+@@ -215,13 +215,16 @@
--USE_SKBUILD = True
-+USE_SKBUILD = False
- if USE_SKBUILD:
-
- if '--universal' in sys.argv:
-@@ -181,6 +181,7 @@
- try:
- from Cython.Distutils import build_ext
-+ from Cython.Build import cythonize
- cmdclass = dict(build_ext=build_ext)
- line_profiler_source = '_line_profiler.pyx'
- except ImportError:
- cmdclass = {}
-@@ -196,12 +197,13 @@
+ if __name__ == '__main__':
+- if '--universal' in sys.argv:
+- # Dont use scikit-build for universal wheels
+- # if 'develop' in sys.argv:
+- sys.argv.remove('--universal')
+- from setuptools import setup # NOQA
+- else:
+- from skbuild import setup
++ from setuptools import setup # NOQA
++ from setuptools.extension import Extension
++ from Cython.Build import cythonize
++ extension = Extension('line_profiler._line_profiler',
++ sources=["line_profiler/_line_profiler.pyx",
++ 'line_profiler/timers.c',
++ 'line_profiler/unset_trace.c'],
++ depends=['python25.pxd'],
++ extra_compile_args=["-DHAVE_GETTIMEOFDAY"])
++ extension = cythonize([extension])
setupkw = dict(
- cmdclass=cmdclass,
- ext_modules=[
-- Extension('_line_profiler',
-- sources=[line_profiler_source, 'timers.c', 'unset_trace.c'],
-- depends=['python25.pxd']),
-+ Extension('line_profiler._line_profiler',
-+ sources=["line_profiler/_line_profiler.pyx", 'line_profiler/timers.c', 'line_profiler/unset_trace.c'],
-+ depends=['python25.pxd'],
-+ extra_compile_args=["-DHAVE_GETTIMEOFDAY"]),
+ name=NAME,
+ version=VERSION,
+@@ -251,6 +254,7 @@
+ 'Topic :: Software Development',
],
- )
--
-+setupkw["ext_modules"] = cythonize(setupkw["ext_modules"])
- long_description = """\
- line_profiler will profile the time individual lines of code take to execute.
- The profiler is implemented in C via Cython in order to reduce the overhead of
+ # py_modules=find_packages(),
++ ext_modules=extension,
+ packages=list(find_packages()),
+ py_modules=['kernprof', 'line_profiler'],
+ entry_points={