summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-05-24 14:43:30 -0400
committerGuillaume Horel2022-05-24 14:44:17 -0400
commitac2112bac6a2674e2faa134899754f824a3a7235 (patch)
treece711d098037ed151b50e757333c80edf369fe0f
parent8fb51bb688f0b1e959afe7762e13bd18913178dc (diff)
downloadaur-ac2112bac6a2674e2faa134899754f824a3a7235.tar.gz
enable pytest tests
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 815b34b13e6b..0df77befa27e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,8 @@ pkgbase = python-lineprofiler
url = https://pypi.python.org/pypi/line_profiler
arch = x86_64
license = BSD
+ checkdepends = python-pytest
+ checkdepends = python-ubelt
makedepends = cython
depends = python-setuptools
depends = ipython
diff --git a/PKGBUILD b/PKGBUILD
index 7a693f52041f..03923b7a625f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,7 @@ arch=('x86_64')
license=('BSD')
depends=('python-setuptools' 'ipython')
makedepends=('cython')
+checkdepends=('python-pytest' 'python-ubelt')
source=("$_pkgname-$pkgver.tar.gz::https://github.com/pyutils/line_profiler/archive/v$pkgver.tar.gz"
"cython.patch")
@@ -31,7 +32,7 @@ build() {
check() {
cd "$_pkgname-${pkgver}"
python setup.py build_ext --inplace
- python -m unittest discover -v tests
+ PYTHONPATH=. pytest tests
}
package() {