summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlithery2018-04-04 19:10:38 +0100
committerSlithery2018-04-04 19:10:38 +0100
commite481fccb6e4950f584f86ec9f114e73777da8966 (patch)
tree31e8644db3a7821ac5663864eeb2bc150c3000b4
downloadaur-e481fccb6e4950f584f86ec9f114e73777da8966.tar.gz
Initial upload: python-linode-api 4.1.8b1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6a00706c83b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-linode-api
+ pkgdesc = Bindings for the Linode API v4
+ pkgver = 4.1.8b1
+ pkgrel = 1
+ url = https://github.com/linode/python-linode-api
+ arch = any
+ license = BSD
+ depends = python
+ source = https://github.com/linode/python-linode-api/archive/v4.1.8b1.zip
+ sha256sums = f2e84dac7e89484756a8bb81054efb2cf3bb13362323e367036412adacf09432
+
+pkgname = python-linode-api
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e3a8253e260
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Slithery <aur at slithery dot uk>
+pkgname=python-linode-api
+pkgver=4.1.8b1
+pkgrel=1
+pkgdesc="Bindings for the Linode API v4"
+arch=('any')
+url="https://github.com/linode/$pkgname"
+license=('BSD')
+depends=('python')
+source=("$url/archive/v$pkgver.zip")
+sha256sums=('f2e84dac7e89484756a8bb81054efb2cf3bb13362323e367036412adacf09432')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgbase/LICENSE"
+}