summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Rutkowski2018-12-28 22:28:14 +0100
committerAdam Rutkowski2018-12-28 22:37:08 +0100
commit26cbbd2084236c3e5079c1e16aa8e6fe6490aa1f (patch)
treeb50b6be4eff6b36fbd3ccbdb5ec46fee5fd0d95f
downloadaur-26cbbd2084236c3e5079c1e16aa8e6fe6490aa1f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e79a2b9fb30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-liquidctl
+ pkgdesc = Cross-platform tool and drivers for liquid coolers and other devices
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/jonasmalacofilho/liquidctl
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = libusb
+ source = https://files.pythonhosted.org/packages/source/l/liquidctl/liquidctl-1.1.0.tar.gz
+ md5sums = 1fcf5a49e73c3799f49fb6a977b6cde9
+
+pkgname = python-liquidctl
+ depends = python
+ depends = libusb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e84b6182dd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=('python-liquidctl')
+_module='liquidctl'
+pkgver='1.1.0'
+pkgrel=1
+pkgdesc="Cross-platform tool and drivers for liquid coolers and other devices"
+url="https://github.com/jonasmalacofilho/liquidctl"
+depends=('python' 'libusb')
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/l/liquidctl/liquidctl-${pkgver}.tar.gz")
+md5sums=('1fcf5a49e73c3799f49fb6a977b6cde9')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}