summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-02-04 20:56:05 +0100
committerCarl Smedstad2024-02-04 20:56:05 +0100
commite10bfdd109d867640d968c4a60177a85ad35ea28 (patch)
tree63396bbd98ac1c1358c89dc3284ca1c48230d64e
parentd4ae5d345c485a9e8bd4ac9c98a0a9686e60c04d (diff)
downloadaur-e10bfdd109d867640d968c4a60177a85ad35ea28.tar.gz
upgpkg: 2.5.5-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66abada0fd52..0c4d8fb41064 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-litestar
pkgdesc = Production-ready, Light, Flexible and Extensible ASGI API framework
- pkgver = 2.5.4
+ pkgver = 2.5.5
pkgrel = 1
url = https://github.com/litestar-org/litestar
arch = any
@@ -71,7 +71,7 @@ pkgbase = python-litestar
optdepends = python-opentelemetry-sdk: OpenTelemetry instrumentation
optdepends = python-redis: Redis store
optdepends = python-sqlalchemy: SQLAlchemy integration
- source = python-litestar-2.5.4.tar.gz::https://github.com/litestar-org/litestar/archive/refs/tags/v2.5.4.tar.gz
- sha256sums = be6155faa46fd1d843fb4d1ea8d3721f212f0ae79f27826251fe78d2cef5777a
+ source = python-litestar-2.5.5.tar.gz::https://github.com/litestar-org/litestar/archive/refs/tags/v2.5.5.tar.gz
+ sha256sums = 6d7dfb82d49ffa47c4a3592bfeb7b9cd7633127ee4015e0bddba19075e5fd649
pkgname = python-litestar
diff --git a/PKGBUILD b/PKGBUILD
index 846ab60043ba..522f5d47d458 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
pkgname=python-litestar
-_name=${pkgname#python-}
-pkgver=2.5.4
+_pkgname=${pkgname#python-}
+pkgver=2.5.5
pkgrel=1
pkgdesc="Production-ready, Light, Flexible and Extensible ASGI API framework"
arch=(any)
@@ -87,9 +87,9 @@ optdepends=(
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('be6155faa46fd1d843fb4d1ea8d3721f212f0ae79f27826251fe78d2cef5777a')
+sha256sums=('6d7dfb82d49ffa47c4a3592bfeb7b9cd7633127ee4015e0bddba19075e5fd649')
-_archive="$_name-$pkgver"
+_archive="$_pkgname-$pkgver"
build() {
cd "$_archive"
@@ -128,9 +128,8 @@ check() {
_deselected_tests=(
# Fails for unkown reason
- tests/unit/test_cli/test_core_commands.py::test_routes_command_options
- tests/unit/test_template/test_template.py::test_media_type_inferred
tests/unit/test_middleware/test_middleware_handling.py::test_custom_middleware_processing
+ tests/unit/test_template/test_template.py::test_media_type_inferred
# Requires running docker compose
tests/e2e/test_response_caching.py::test_with_stores