summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Jamison2018-06-10 07:43:33 -0500
committerCaleb Jamison2018-06-10 07:43:33 -0500
commit14f234f1a0f40bac0214432d5f9fa0af8b4cb098 (patch)
tree10078f94df3159c838b5a9dc691c0dd47dd9f9b5
downloadaur-14f234f1a0f40bac0214432d5f9fa0af8b4cb098.tar.gz
PKGBUILD and .SRCINFO for LiteVideo
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..358de2db7866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = litevideo-git
+ pkgdesc = Small footprint and configurable video cores
+ pkgver = 201
+ pkgrel = 1
+ url = https://github.com/enjoy-digital/litevideo
+ arch = any
+ license = MIT
+ depends = python
+ depends = migen
+ depends = litex
+ provides = litevideo
+ options = !emptydirs
+ source = git+https://github.com/enjoy-digital/litevideo
+ sha256sums = SKIP
+
+pkgname = litevideo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4515b5b59ca1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Caleb Jamison <cbjamo@gmail.com>
+pkgname=litevideo-git
+pkgver=201
+pkgrel=1
+pkgdesc="Small footprint and configurable video cores"
+arch=(any)
+url="https://github.com/enjoy-digital/litevideo"
+license=('MIT')
+groups=()
+depends=('python' 'migen' 'litex')
+provides=('litevideo')
+options=(!emptydirs)
+install=
+source=("git+https://github.com/enjoy-digital/litevideo")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%%-git}"
+ git rev-list --count HEAD
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%%-git}"
+ rm -rf test/__init__.py
+}
+
+build() {
+ cd "${srcdir}/${pkgname%%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname%%-git}"
+ python setup.py install --root="$pkgdir/" --skip-build --optimize=1
+}
+