summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2022-05-10 17:27:01 +0800
committerPumpkinCheshire2022-05-10 17:27:01 +0800
commite2bfb134375c2ebdb88b19c6ebe124dce750540e (patch)
tree25eedb2c1c47add15dc50f67e2246340bc0b8bb5
downloadaur-e2bfb134375c2ebdb88b19c6ebe124dce750540e.tar.gz
init 1.17.10
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78b9cb29aedc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-lizard
+ pkgdesc = A code analyzer without caring the C/C++ header files. It works with Java, C/C++, JavaScript, Python, Ruby, Swift, Objective C. Metrics includes cyclomatic complexity number etc.
+ pkgver = 1.17.10
+ pkgrel = 1
+ url = https://github.com/terryyin/lizard
+ arch = any
+ license = custom
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ source = https://files.pythonhosted.org/packages/source/l/lizard/lizard-1.17.10.tar.gz
+ b2sums = 9b2e3e65430b57ab0a5a48ac36c3fd045cdcdbad5612b40091f73b1641c4eb724c604aa23a04cc16542c423fd6c811e36a910a31b247f011ae44b40477e9bd54
+
+pkgname = python-lizard
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b49a4ce26b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+#!/bin/bash
+
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot com>
+
+_name=lizard
+pkgname=python-lizard
+pkgver=1.17.10
+pkgrel=1
+pkgdesc="A code analyzer without caring the C/C++ header files. It works with Java, C/C++, JavaScript, Python, Ruby, Swift, Objective C. Metrics includes cyclomatic complexity number etc."
+arch=('any')
+url="https://github.com/terryyin/lizard"
+license=('custom')
+depends=()
+makedepends=('python-wheel'
+ 'python-build'
+ 'python-installer'
+)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+b2sums=('9b2e3e65430b57ab0a5a48ac36c3fd045cdcdbad5612b40091f73b1641c4eb724c604aa23a04cc16542c423fd6c811e36a910a31b247f011ae44b40477e9bd54')
+
+build() {
+ cd "$srcdir/$_name-$pkgver" || exit
+
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver" || exit
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ # install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/python-$_name/LICENSE"
+}