summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Iozzelli2016-09-04 11:31:07 +0200
committerYuri Iozzelli2016-09-04 11:31:07 +0200
commitced8a8a0a76adf5a8f8f283348442ede5af6ca4e (patch)
treea2eb0932cc0c40e754cbfb427cf3e60ff6c2fa62
downloadaur-ced8a8a0a76adf5a8f8f283348442ede5af6ca4e.tar.gz
pre-compiled version of python-llvmlite (to avoid problems with llvm versions). first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e27bcb48a791
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-llvmlite-bin
+ pkgdesc = A lightweight LLVM python binding for writing JIT compilers
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = http://llvmlite.pydata.org
+ arch = x86_64
+ license = GPL
+ depends = python
+ provides = python-llvmlite
+ conflicts = python-llvmlite
+ source = https://anaconda.org/numba/llvmlite/0.11.0/download/linux-64/llvmlite-0.11.0-py35_0.tar.bz2
+ md5sums = 27e16301d127831def3b3360872db7b8
+
+pkgname = python-llvmlite-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4d04e7a6234
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Yuri Iozzelli <y.iozzelli@gmail.com>
+pkgname=python-llvmlite-bin
+pkgver=0.13.0
+pkgrel=1
+epoch=
+pkgdesc="A lightweight LLVM python binding for writing JIT compilers"
+arch=("x86_64")
+url="http://llvmlite.pydata.org"
+license=('GPL')
+groups=()
+depends=("python")
+provides=("python-llvmlite")
+conflicts=("python-llvmlite")
+source=("https://anaconda.org/numba/llvmlite/$pkgver/download/linux-64/llvmlite-$pkgver-py35_0.tar.bz2")
+md5sums=('ca51ff181f85b1a073ca15fd598cc0b8')
+
+package() {
+ cd "$srcdir/lib/python3.5/site-packages"
+ mkdir -p "$pkgdir/usr/lib/python3.5/site-packages/"
+ cp -r * "$pkgdir/usr/lib/python3.5/site-packages/"
+}