summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuan Guo2015-06-17 21:31:13 +0200
committerQuan Guo2015-06-17 21:31:13 +0200
commit7e87e56ff98039c5eb8cf151c2b8e6348c31a747 (patch)
tree9fd13ffb478b8295749f979a801d3c5ab967cb64
downloadaur-7e87e56ff98039c5eb8cf151c2b8e6348c31a747.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd21c4ce246c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-llvmlite-git
+ pkgdesc = A lightweight LLVM python binding for writing JIT compilers
+ pkgver = 0.4.0.r70.g423d5a3
+ pkgrel = 1
+ url = https://github.com/numba/llvmlite
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cython
+ depends = python
+ depends = llvm
+ provides = python-llvmlite
+ source = git+https://github.com/numba/llvmlite.git#branch=llvm3.6
+ md5sums = SKIP
+
+pkgname = python-llvmlite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6ee5684a663
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Quan Guo <guotsuan at gmail dot com>
+
+pkgname=python-llvmlite-git
+pkgver=0.4.0.r70.g423d5a3
+pkgrel=1
+pkgdesc="A lightweight LLVM python binding for writing JIT compilers"
+url="https://github.com/numba/llvmlite"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('python' 'llvm')
+makedepends=('git' 'cython')
+provides=('python-llvmlite')
+conflicts=()
+replaces=()
+backup=()
+source=(git+https://github.com/numba/llvmlite.git#branch=llvm3.6)
+md5sums=('SKIP')
+
+_gitname=llvmlite
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd ${srcdir}/${_gitname}
+ python setup.py install \
+ --prefix=/usr \
+ --root=$pkgdir
+}