summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-04-28 23:15:18 -0300
committerDaniel Bermond2017-04-28 23:15:18 -0300
commitdfb4bdd0899f3c8a54455dd9ee44e5ce7cec9bd1 (patch)
treeab208f67d773afa22c707a0643d09e8c0f133f3e
downloadaur-dfb4bdd0899f3c8a54455dd9ee44e5ce7cec9bd1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e64653d7f4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Apr 29 02:14:28 UTC 2017
+pkgbase = python-lmdb
+ pkgdesc = Universal Python3 binding for the LMDB Lightning Database
+ pkgver = 0.92
+ pkgrel = 1
+ url = https://github.com/dw/py-lmdb/
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ depends = lmdb
+ source = https://github.com/dw/py-lmdb/archive/py-lmdb_0.92.tar.gz
+ sha256sums = 8bed442e5b3dae112613c5f305547575941a7dac2aaa70b2ce68506dd4371a0e
+
+pkgname = python-lmdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbeda99caa17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+
+pkgname=python-lmdb
+pkgver=0.92
+pkgrel=1
+pkgdesc="Universal Python3 binding for the LMDB Lightning Database"
+arch=('any')
+url="https://github.com/dw/py-lmdb/"
+license=('custom')
+depends=('python' 'lmdb')
+makedepends=('python-setuptools')
+source=("https://github.com/dw/py-lmdb/archive/py-lmdb_${pkgver}.tar.gz")
+sha256sums=('8bed442e5b3dae112613c5f305547575941a7dac2aaa70b2ce68506dd4371a0e')
+
+build() {
+ cd "py-lmdb-py-lmdb_$pkgver"
+ LMDB_FORCE_SYSTEM=1 python setup.py build
+}
+
+package() {
+ cd "py-lmdb-py-lmdb_$pkgver"
+ LMDB_FORCE_SYSTEM=1 python setup.py install --root="$pkgdir" --optimize=1
+
+ # license
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}