summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-06-06 10:50:53 +0100
committerGrey Christoforo2019-06-06 10:50:53 +0100
commit6937df645f17663ff38a532c8b60bb88004e0ac5 (patch)
treec2a81e459a1a8948546ac0eb7cadb84d5f3f2d0c
parent0f0fb54c74e69a2063009b11d212cc8a78fd4104 (diff)
downloadaur-6937df645f17663ff38a532c8b60bb88004e0ac5.tar.gz
version bump
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD35
2 files changed, 17 insertions, 25 deletions
diff --git a/.gitignore b/.gitignore
index 6ae0b18a1f6c..72a3ed3fe6e0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
-/pkg
-/src
-*.tar.gz
-*.tar.xz
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 9954a32a4a28..59784a7569f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,26 @@
-# Maintainer: Grey Christoforo <first name at last name dot net>
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
-pkgbase=python-lmfit
-pkgname=('python-lmfit' 'python2-lmfit')
-pkgver=0.9.11
+pkgname=python-lmfit
+pkgver=0.9.13
pkgrel=1
-pkgdesc="Least-Squares Minimization with Constraints for Python"
+pkgdesc="Non-Linear Least Squares Minimization, with flexible Parameter settings, based on scipy.optimize.leastsq, and with many additional classes and methods for curve fitting"
arch=('any')
-url="http://lmfit.github.io/lmfit-py/"
-license=('BSD')
+url=http:/lmfit.github.io/lmfit-py/
+license=('BSD-3')
+depends=('python' 'python-numpy' 'python-scipy' 'python-asteval')
+makedepends=(python-setuptools)
source=(https://github.com/lmfit/lmfit-py/archive/${pkgver}.tar.gz)
-md5sums=('227d48cf785119e4a249b2b5626ebbba')
+sha256sums=('b604afca0aaa23b28170065853b59d6e4c585c367e537b769813af313f8ebeed')
-#check() {
-# cd "$srcdir/lmfit-py-$pkgver"
-# nosetests3 tests
-#}
-
-package_python-lmfit(){
- #checkdepends=('python-nose')
- depends=('python' 'python-numpy' 'python-scipy' 'python-asteval')
+build() {
cd "$srcdir/lmfit-py-$pkgver"
- python setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py build
}
-package_python2-lmfit(){
- #checkdepends=('python2-nose')
- depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-asteval')
+
+package(){
cd "$srcdir/lmfit-py-$pkgver"
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
# vim:ts=2:sw=2:et: