summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2015-06-09 21:54:57 -0400
committerFrançois Boulogne2015-06-09 21:54:57 -0400
commit8dcf00042e5a20e120035ea17dc3a15a2a1bb757 (patch)
tree575e18086d0d20e95cb2690e2ccd37390d189dd4
downloadaur-8dcf00042e5a20e120035ea17dc3a15a2a1bb757.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e04c326966b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-lmfit
+ pkgdesc = Least-Squares Minimization with Constraints for Python
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = http://lmfit.github.io/lmfit-py/
+ arch = any
+ license = BSD
+ checkdepends = python-nose
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ source = https://github.com/lmfit/lmfit-py/archive/0.8.3.tar.gz
+ md5sums = f5a06cf18611f3dc323e3a1bab8d45fa
+
+pkgname = python-lmfit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..277f87cee2f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Francois Boulogne <fboulogne at april dot org>
+
+pkgname=python-lmfit
+pkgver=0.8.3
+pkgrel=1
+pkgdesc="Least-Squares Minimization with Constraints for Python"
+arch=('any')
+url="http://lmfit.github.io/lmfit-py/"
+license=('BSD')
+depends=('python' 'python-numpy' 'python-scipy')
+makedepends=('python-setuptools')
+checkdepends=('python-nose')
+source=(https://github.com/lmfit/lmfit-py/archive/${pkgver}.tar.gz)
+
+build() {
+ cd "$srcdir/lmfit-py-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$srcdir/lmfit-py-$pkgver"
+ nosetests3 tests
+}
+
+package(){
+ cd "$srcdir/lmfit-py-$pkgver"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim:ts=2:sw=2:et:
+md5sums=('f5a06cf18611f3dc323e3a1bab8d45fa')