summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStick2019-11-20 21:55:03 -0500
committerStick2019-11-20 21:55:03 -0500
commit204ca9992dcd4f414de77f85ee325e8de9bc610e (patch)
tree2b3190d72d1d80ddbbb2763e8202dfc334f621d4
parent41b38e4b9dd610459dcf4b9d57c6329894ec3e96 (diff)
downloadaur-204ca9992dcd4f414de77f85ee325e8de9bc610e.tar.gz
bringing it back
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD51
3 files changed, 58 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34a82f6d35a2..671899fc60ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
-# Generated by mksrcinfo v8
-# Sat Dec 30 04:56:57 UTC 2017
pkgbase = python-locust-git
- pkgdesc = An easy-to-use, distributed, user load testing tool.
- pkgver = v0.8.1.67.g387e7a8
+ pkgdesc = Scalable user load testing tool written in Python
+ pkgver = 0.13.2.r6.g989fa24
pkgrel = 1
- url = http://locust.io/
+ url = https://github.com/locustio/locust
arch = any
license = MIT
makedepends = git
makedepends = python-setuptools
- depends = python-gevent
depends = python-flask
- depends = python-requests
+ depends = python-gevent
+ depends = python-geventhttpclient-wheels
depends = python-msgpack
depends = python-pyzmq
+ depends = python-requests
depends = python-six
- source = git+https://github.com/locustio/locust
+ provides = python-locust
+ conflicts = python-locust
+ source = python-locust-git::git+https://github.com/locustio/locust
md5sums = SKIP
pkgname = python-locust-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6b4a8512010
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
index fbc743147316..8d953a343a53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,44 @@
-# Maintainer: Sherlock Holo <Sherlockya@gmail.com>
-pkgname=python-locust-git
-_pkgname=locust
-pkgver=v0.8.1.67.g387e7a8
+# Maintainer: Stick <stick@stma.is>
+# Contributer: Sherlock Holo <Sherlockya@gmail.com>
+
+_pkg=locust
+pkgname="python-$_pkg-git"
+pkgver=0.13.2.r6.g989fa24
pkgrel=1
-pkgdesc="An easy-to-use, distributed, user load testing tool."
+pkgdesc="Scalable user load testing tool written in Python"
arch=('any')
-url="http://locust.io/"
+url="https://github.com/locustio/$_pkg"
license=('MIT')
-depends=('python-gevent' 'python-flask' 'python-requests' 'python-msgpack' 'python-pyzmq' 'python-six')
-makedepends=('git' 'python-setuptools')
-source=('git+https://github.com/locustio/locust')
+depends=('python-flask'
+ 'python-gevent'
+ 'python-geventhttpclient-wheels'
+ 'python-msgpack'
+ 'python-pyzmq'
+ 'python-requests'
+ 'python-six')
+makedepends=('git'
+ 'python-setuptools')
+provides=("python-$_pkg")
+conflicts=("python-$_pkg")
+source=("$pkgname::git+$url")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --tags | sed "s/-/./g"
+ cd "$pkgname" || exit
+ local _ver
+ _ver="$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+ printf '%s\n' "${_ver#v}"
}
+
build() {
- cd $srcdir
- cd $_pkgname
- sed -i "s/gevent>=1.2.2/gevent/" setup.py
- sed -i "s/flask>=0.10.1/flask/" setup.py
- sed -i "s/requests>=2.9.1/requests/" setup.py
- sed -i "s/msgpack-python>=0.4.2/msgpack-python/" setup.py
- sed -i "s/six>=1.10.0/six/" setup.py
- sed -i "s/pyzmq>=16.0.2/pyzmq/" setup.py
+ cd "$pkgname" || exit
+ sed -i 's/msgpack-python/msgpack/' setup.py
+ sed -i 's/ "\([[:alpha:]-]*\).=.*"/ "\1"/' setup.py
python setup.py build
}
package() {
- cd $srcdir/$_pkgname
- python setup.py install --skip-build --root=${pkgdir}/ --optimize=1
+ cd "$pkgname" || exit
+ python setup.py install --skip-build --root="$pkgdir"/ --optimize=1
}