summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSherlock Holo2017-10-08 12:30:10 +0800
committerSherlock Holo2017-10-08 12:30:10 +0800
commitd79aadeffc9e90501f302dc4089cde610e075325 (patch)
tree4807d09f07e134b5825e22e9acc9145a7a6679eb
parent54817e5981fb62efca935647193bf7fc1f67cca0 (diff)
downloadaur-d79aadeffc9e90501f302dc4089cde610e075325.tar.gz
Refine pkgbuild
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
-rw-r--r--locust.patch11
3 files changed, 17 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cce10a738dc0..b6db386cf108 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Sep 12 18:33:07 UTC 2017
+# Sun Oct 8 04:30:03 UTC 2017
pkgbase = python-locust-git
pkgdesc = An easy-to-use, distributed, user load testing tool.
- pkgver = v0.8a1.82.g8c4eeae
- pkgrel = 5
+ pkgver = v0.8.45.g71e4864
+ pkgrel = 1
url = http://locust.io/
arch = any
license = MIT
@@ -14,10 +14,9 @@ pkgbase = python-locust-git
depends = python-requests
depends = python-msgpack
depends = python-pyzmq
- source = git://github.com/locustio/locust.git
- source = locust.patch
+ depends = python-six
+ source = git+https://github.com/locustio/locust
md5sums = SKIP
- md5sums = cd7c5b5fafcd7ca2561ea9450b4bf26a
pkgname = python-locust-git
diff --git a/PKGBUILD b/PKGBUILD
index 57f1a47dd6cb..ff1038dfec38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,16 @@
# Maintainer: Sherlock Holo <Sherlockya@gmail.com>
pkgname=python-locust-git
_pkgname=locust
-pkgver=v0.8a1.82.g8c4eeae
-pkgrel=5
+pkgver=v0.8.45.g71e4864
+pkgrel=1
pkgdesc="An easy-to-use, distributed, user load testing tool."
arch=('any')
url="http://locust.io/"
license=('MIT')
-depends=('python-gevent' 'python-flask' 'python-requests' 'python-msgpack' 'python-pyzmq')
+depends=('python-gevent' 'python-flask' 'python-requests' 'python-msgpack' 'python-pyzmq' 'python-six')
makedepends=('git' 'python-setuptools')
-source=('git://github.com/locustio/locust.git'
- 'locust.patch')
-md5sums=('SKIP'
- 'cd7c5b5fafcd7ca2561ea9450b4bf26a')
+source=('git+https://github.com/locustio/locust')
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -21,13 +19,17 @@ pkgver() {
build() {
cd $srcdir
- mv locust.patch $_pkgname
cd $_pkgname
- patch -p0 -i locust.patch
+ sed -i "s/gevent>=1.2.2/gevent/" setup.py
+ sed -i "s/flask>=0.10.1/flask/" setup.py
+ sed -i "s/requests>=2.9.1/requests/" setup.py
+ sed -i "s/msgpack-python>=0.4.2/msgpack-python/" setup.py
+ sed -i "s/six>=1.10.0/six/" setup.py
+ sed -i "s/pyzmq>=16.0.2/pyzmq/" setup.py
python setup.py build
}
package() {
cd $srcdir/$_pkgname
- python setup.py install --root=${pkgdir}/ --optimize=1
+ python setup.py install --skip-build --root=${pkgdir}/ --optimize=1
}
diff --git a/locust.patch b/locust.patch
deleted file mode 100644
index 533bae0e91ce..000000000000
--- a/locust.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py 2017-09-13 02:26:46.059568199 +0800
-+++ setup.py 2017-09-13 02:27:39.156296051 +0800
-@@ -41,7 +41,7 @@
- packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
- include_package_data=True,
- zip_safe=False,
-- install_requires=["gevent>=1.2.2", "flask>=0.10.1", "requests>=2.9.1", "msgpack-python>=0.4.2", "six>=1.10.0", "pyzmq==15.2.0"],
-+ install_requires=["gevent", "flask", "requests", "msgpack-python", "pyzmq"],
- tests_require=['unittest2', 'mock'],
- entry_points={
- 'console_scripts': [