summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-04-01 09:41:26 -0500
committerLuis Martinez2022-04-01 09:41:26 -0500
commit4d7a4254376db4d28c2c1d1829d10c1d3f83595b (patch)
tree3ac65b9126f722a25777d581a4126e2349423f52
parentfce16a23cc8e320cc0d875f2a1c7729d5e1a5b73 (diff)
downloadaur-4d7a4254376db4d28c2c1d1829d10c1d3f83595b.tar.gz
packaging update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cefd132268ff..5c5665c6aaa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = python-logging_tree
pkgdesc = Introspect and display the logger tree inside "logging"
pkgver = 1.9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/brandon-rhodes/logging_tree
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
provides = python-logging-tree
replaces = python-logging-tree
- source = python-logging_tree-1.9.tar.gz::https://github.com/brandon-rhodes/logging_tree/archive/1.9.tar.gz
- sha256sums = 3e15b37911efcdbc7195199aa20a463fd37a7385251a90600b5df1eb28569c35
+ source = python-logging_tree-1.9.tar.gz::https://files.pythonhosted.org/packages/source/l/logging-tree/logging_tree-1.9.tar.gz
+ sha256sums = fe78b28788c249b515d12a50417e4a96ba095582927b3601a0573886bffc1ff0
pkgname = python-logging_tree
diff --git a/PKGBUILD b/PKGBUILD
index eced80906d02..2ae671b2d8c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,26 @@
pkgname=python-logging_tree
pkgver=1.9
-pkgrel=2
+pkgrel=3
pkgdesc='Introspect and display the logger tree inside "logging"'
url='https://github.com/brandon-rhodes/logging_tree'
license=('BSD')
arch=('any')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
provides=('python-logging-tree')
replaces=('python-logging-tree')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('3e15b37911efcdbc7195199aa20a463fd37a7385251a90600b5df1eb28569c35')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/l/logging-tree/logging_tree-$pkgver.tar.gz")
+sha256sums=('fe78b28788c249b515d12a50417e4a96ba095582927b3601a0573886bffc1ff0')
+
+prepare() {
+ cd "logging_tree-$pkgver"
+ sed -i "/packages=/c\packages=['logging_tree']," setup.py
+}
build() {
cd "logging_tree-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -27,6 +32,6 @@ check() {
package() {
cd "logging_tree-$pkgver"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm 644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}