summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh VanderLinden2015-09-11 22:57:40 -0600
committerJosh VanderLinden2015-09-11 22:58:21 -0600
commit4dbe6e77980fb0a15f976bcb70d5eb49a8c1e088 (patch)
treebabd56988e00534bf4894f908c9dfa6caf5370f7
downloadaur-4dbe6e77980fb0a15f976bcb70d5eb49a8c1e088.tar.gz
Initial package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1ecb4e66dfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-logstash
+ pkgdesc = Python logging handler for Logstash
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = https://github.com/vklochan/python-logstash
+ arch = any
+ license = MIT
+ source = https://pypi.python.org/packages/source/p/python-logstash/python-logstash-0.4.5.tar.gz
+ md5sums = 401462a61563f992894bd65c976e556b
+
+pkgname = python-logstash
+
+pkgname = python2-logstash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56d8c89497af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Josh VanderLinden <arch@cloudlery.com>
+_base=logstash
+pkgname=(
+ python-${_base}
+ python2-${_base}
+)
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="Python logging handler for Logstash"
+arch=('any')
+url="https://github.com/vklochan/python-logstash"
+license=('MIT')
+source=("https://pypi.python.org/packages/source/p/python-${_base}/python-${_base}-${pkgver}.tar.gz")
+md5sums=('401462a61563f992894bd65c976e556b')
+
+_inst() {
+ depends=("${1}" "${1}-setuptools")
+
+ cd python-${_base}-${pkgver}/
+ ${1} setup.py install --optimize 1 --root "${pkgdir}/"
+
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+package_python-logstash() {
+ _inst python
+}
+
+package_python2-logstash() {
+ _inst python2
+}
+
+# vim:set ts=2 sw=2 et: