summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShakil Shaikh2021-02-16 20:32:28 +0000
committerShakil Shaikh2021-02-16 20:32:28 +0000
commitb48a6aa9a2c0876e0cc69ce1bce757b19e639307 (patch)
treebb73d60974fb85319feb8f8ab3c5d97cc793203a
downloadaur-b48a6aa9a2c0876e0cc69ce1bce757b19e639307.tar.gz
Initial submission
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD27
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b00fb7aba2f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = python-london-unified-prayer-times
+ pkgdesc = A library for retrieving data from The London Unified Prayer Timetable.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/sshaikh/london_unified_prayer_times
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-click-default-group
+ depends = python-jsonschema
+ depends = python-dateutil
+ depends = python-appdirs
+ depends = python-tzlocal
+ depends = python-humanize
+ source = https://files.pythonhosted.org/packages/source/l/london_unified_prayer_times/london_unified_prayer_times-1.0.1.tar.gz
+ sha256sums = c0356ac8770cfb47163efcd4d3826d614761e0f815f646e575d6d9881adbe0f7
+
+pkgname = python-london-unified-prayer-times
+ depends = python
+ depends = python-click
+ depends = python-click-default-group
+ depends = python-jsonschema
+ depends = python-dateutil
+ depends = python-appdirs
+ depends = python-tzlocal
+ depends = python-humanize
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69c76eb0e53c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Shakil Shaikh <sshaikh@hotmail.com>
+
+pkgbase='python-london-unified-prayer-times'
+pkgname=('python-london-unified-prayer-times')
+_module='london_unified_prayer_times'
+pkgver='1.0.1'
+pkgrel=1
+pkgdesc="A library for retrieving data from The London Unified Prayer Timetable."
+url="https://github.com/sshaikh/london_unified_prayer_times"
+depends=('python' 'python-click' 'python-click-default-group' 'python-jsonschema'
+'python-dateutil' 'python-appdirs' 'python-tzlocal' 'python-humanize')
+makedepends=('python-setuptools')
+license=('GPL')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('c0356ac8770cfb47163efcd4d3826d614761e0f815f646e575d6d9881adbe0f7')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}