summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-01-12 08:24:41 +0100
committerPhilipp A2018-01-12 08:24:41 +0100
commit158ff95878e4931081dd40af40e8fff30899ad87 (patch)
tree4380ebca28e1863f5d94189e6bc0e03beec5a732
downloadaur-158ff95878e4931081dd40af40e8fff30899ad87.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc73b9edbacc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-loompy
+ pkgdesc = Python implementation of the Loom file format for single-cell RNA-seq data
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = http://loompy.org/
+ arch = any
+ license = BSD
+ depends = python-h5py
+ depends = python-scipy
+ depends = python-numpy
+ source = https://files.pythonhosted.org/packages/source/l/loompy/loompy-1.1.0.tar.gz
+ md5sums = 85ec1d9424fdfe55a4e11b7dca0785eb
+
+pkgname = python-loompy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2628841d3873
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar.gz
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eb7aee5da0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+_name=loompy
+pkgname=python-loompy
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='Python implementation of the Loom file format for single-cell RNA-seq data'
+arch=(any)
+url='http://loompy.org/'
+license=(BSD)
+depends=(python-h5py python-scipy python-numpy)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+md5sums=('85ec1d9424fdfe55a4e11b7dca0785eb')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 || return 1
+}