summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-10-02 09:53:37 +0200
committerPhilipp A2020-10-02 09:53:37 +0200
commitd4cbeb281c5509e86579bdb8bbe8625b9ca27419 (patch)
treeb742907ce6cee2ced179ffcfebd083105ba6dd6c
parent2774167d316b318b9dfeb29aeff3c9e405db080b (diff)
downloadaur-d4cbeb281c5509e86579bdb8bbe8625b9ca27419.tar.gz
v3.0.6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7146e3cea161..a6e5fe552fbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-loompy
pkgdesc = Python implementation of the Loom file format for single-cell RNA-seq data
- pkgver = 2.0.17
+ pkgver = 3.0.6
pkgrel = 1
url = http://loompy.org/
arch = any
@@ -8,8 +8,11 @@ pkgbase = python-loompy
depends = python-h5py
depends = python-scipy
depends = python-numpy
- source = https://files.pythonhosted.org/packages/source/l/loompy/loompy-2.0.17.tar.gz
- sha256sums = fa608019cb29569704fefb07486f579e21bfc4dc5949fdf56b8e1b31ee6b2982
+ depends = python-numba
+ depends = python-click
+ depends = python-numpy-groupies
+ source = https://files.pythonhosted.org/packages/source/l/loompy/loompy-3.0.6.tar.gz
+ sha256sums = 58e9763b8ab1af2a4a0e3805d120458b5184fd2b0f3031657ecce33c63ca4c46
pkgname = python-loompy
diff --git a/PKGBUILD b/PKGBUILD
index f07fa6c61b78..be2d1a7e698a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,24 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
_name=loompy
pkgname=python-loompy
-pkgver=2.0.17
+pkgver=3.0.6
pkgrel=1
pkgdesc='Python implementation of the Loom file format for single-cell RNA-seq data'
arch=(any)
url='http://loompy.org/'
license=(BSD)
-depends=(python-h5py python-scipy python-numpy)
+depends=(
+ python-h5py
+ python-scipy
+ python-numpy
+ python-numba
+ python-click
+ python-numpy-groupies
+)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('fa608019cb29569704fefb07486f579e21bfc4dc5949fdf56b8e1b31ee6b2982')
+sha256sums=('58e9763b8ab1af2a4a0e3805d120458b5184fd2b0f3031657ecce33c63ca4c46')
package() {
cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 || return 1
+ python setup.py install --root="$pkgdir" --optimize=1
}