summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-07-20 16:49:52 +0200
committerPhilipp A2017-07-20 16:49:52 +0200
commit327cc83970d374484b29eaea07d68335cd4e25d0 (patch)
tree09e60101d9da0d342db89172cb6871bce52fd41f
downloadaur-327cc83970d374484b29eaea07d68335cd4e25d0.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76b1a0e91ed5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-louvain
+ pkgdesc = Python library for validating Python data structures.
+ pkgver = 0.8
+ pkgrel = 1
+ url = https://github.com/taynaud/python-louvain
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/python-louvain/python-louvain-0.8.tar.gz
+ sha256sums = 7cdc7bcb6a8b2f5599b4826315b84bc390b4f964b644cdef781fb7e0ebf4c006
+
+pkgname = python-louvain
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..24f2ec57e666
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..975d2f36ed98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+pkgname=python-louvain
+pkgver=0.8
+pkgrel=1
+pkgdesc='Python library for validating Python data structures.'
+arch=(any)
+url="https://github.com/taynaud/$pkgname"
+license=(BSD)
+depends=(python)
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('7cdc7bcb6a8b2f5599b4826315b84bc390b4f964b644cdef781fb7e0ebf4c006')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}