summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2023-12-27 11:38:10 +0100
committerMaxime Gauduin2023-12-27 11:38:10 +0100
commit38ecf942c1028b8d071341be3f1a88db2c6be9c1 (patch)
tree42d5b265a852abcea531c417308cbd7d1ffeecec
parent623a01ed78340c9ab57bed3041a1bb0872aba829 (diff)
downloadaur-python-lru-dict.tar.gz
drop setup.py
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 077f6f6fe346..5b79fd2b55c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = python-lru-dict
pkgdesc = A fast and memory efficient LRU cache for Python
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/amitdev/lru-dict
arch = x86_64
license = MIT
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = glibc
depends = python
source = git+https://github.com/amitdev/lru-dict.git#tag=51c2761d94fd6fc85faea550240814938d1594f9
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a5c3d05a0e04..8543b4921ea8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,21 @@
pkgname=python-lru-dict
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='A fast and memory efficient LRU cache for Python'
arch=(x86_64)
url=https://github.com/amitdev/lru-dict
license=(MIT)
-depends=(python)
+depends=(
+ glibc
+ python
+)
makedepends=(
git
+ python-build
+ python-installer
python-setuptools
+ python-wheel
)
_tag=51c2761d94fd6fc85faea550240814938d1594f9
source=(git+https://github.com/amitdev/lru-dict.git#tag=${_tag})
@@ -24,13 +30,12 @@ pkgver() {
build() {
cd lru-dict
- python setup.py build_ext
+ python -m build --wheel --no-isolation
}
package() {
- cd lru-dict
- python setup.py install --root="${pkgdir}" --optimize=1
- install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/python-lru-dict/
+ python -m installer --destdir="${pkgdir}" lru-dict/dist/*.whl
+ install -Dm 644 lru-dict/LICENSE -t "${pkgdir}"/usr/share/licenses/python-lru-dict/
}
# vim: ts=2 sw=2 et: