summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2022-08-18 10:40:29 +0000
committerMaxime Gauduin2022-08-18 10:40:29 +0000
commit9dad33edf6236566aad8640d7aa84e9fb97ebd16 (patch)
tree1468923db98a4c8f05eedba480c2bf20164b62ac
parent4e8ee9042b5f3595a2381be4b2c73d444992e242 (diff)
downloadaur-9dad33edf6236566aad8640d7aa84e9fb97ebd16.tar.gz
upgpkg: 1.1.8-1
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6df672567fd..1cdf15af4119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-lru-dict
-pkgver=1.1.7
-pkgrel=2
+pkgver=1.1.8
+pkgrel=1
pkgdesc='A fast and memory efficient LRU cache for Python'
arch=(x86_64)
url=https://github.com/amitdev/lru-dict
@@ -13,10 +13,15 @@ makedepends=(
git
python-setuptools
)
-_commit=64bc69b27dd2b5bcd68c93cce41c8513eb63151e
-source=(git+https://github.com/amitdev/lru-dict.git#commit=${_commit})
+_tag=8bdcd75a11f629aff4b15ec0ae0faaf165a44fb1
+source=(git+https://github.com/amitdev/lru-dict.git#tag=${_tag})
b2sums=(SKIP)
+pkgver() {
+ cd lru-dict
+ git describe --tags | sed 's/^v//'
+}
+
build() {
cd lru-dict
python setup.py build_ext