summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s.2017-09-01 09:03:58 -0400
committerbrent s.2017-09-01 09:03:58 -0400
commit1e6e38d9c2bddc65b73a4e205b59929437feaea7 (patch)
treec2790d2ad80472b34ff682641d6cf4b846054d92
downloadaur-1e6e38d9c2bddc65b73a4e205b59929437feaea7.tar.gz
initial commit; setting up .gitignores and skeleton PKGBUILD
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD29
-rw-r--r--lrzip-1.0.0.tar.gz.sig16
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17197b0c15fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by aurpkgs
+# Fri Sep 01 13:03:58 UTC 2017
+pkgbase = python-lrzip
+ pkgdesc = Python bindings to LRZIP (https://github.com/ckolivas/lrzip)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/lrzip
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ depends = python
+ depends = python2
+ depends = lrzip
+ source = https://files.pythonhosted.org/packages/source/l/lrzip/lrzip-1.0.0.tar.gz
+ source = lrzip-1.0.0.tar.gz.sig
+ sha512sums = ee1aef3199da84754e7b2e0f55d4ee9fbae46a308b811b68f533d04c803f1754be3cac0a1d1809baaff5e267762b9649b7ed6ab0e4ce67187ae6da25ef5d24ca
+ sha512sums = SKIP
+
+pkgname = python-lrzip
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16177da2907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
+*.run
+*.7z
+*.rar
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..517ee4301912
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+pkgname=python-lrzip
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Python bindings to LRZIP (https://github.com/ckolivas/lrzip)"
+arch=( 'i686' 'x86_64' )
+url="https://pypi.python.org/pypi/lrzip"
+license=( 'LGPL3' )
+depends=( 'python' 'python2' 'lrzip' )
+makedepends=( 'python' 'python2' 'lrzip' )
+_pkgname=python-lrzip
+install=
+changelog=
+noextract=()
+source=("https://files.pythonhosted.org/packages/source/l/lrzip/lrzip-1.0.0.tar.gz"
+ "lrzip-1.0.0.tar.gz.sig")
+sha512sums=('ee1aef3199da84754e7b2e0f55d4ee9fbae46a308b811b68f533d04c803f1754be3cac0a1d1809baaff5e267762b9649b7ed6ab0e4ce67187ae6da25ef5d24ca'
+ 'SKIP')
+build() {
+ cd "${srcdir}/${_pkgname}/src"
+ make prefix=${pkgdir}/usr
+}
+package() {
+ install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+}
diff --git a/lrzip-1.0.0.tar.gz.sig b/lrzip-1.0.0.tar.gz.sig
new file mode 100644
index 000000000000..55f9f7ef501e
--- /dev/null
+++ b/lrzip-1.0.0.tar.gz.sig
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCgAdFiEEdIIx68vYCKFPXoXSjABML5NIH2sFAlmpWrUACgkQjABML5NI
+H2tsnBAAzDs3b0mmSJxOSHFHUiAfIExZ/N/LhJ7JJopmsOqejzCeqnFI9ARBk9o0
+e19zzXSF4bV3r8BIMnT8K5WEZfiMYppXzub+auWCZFFYdQCbSbp50mYClYPBT3tA
+wPKAgcdw8A1SbouKO3H8971ywvyLuj7RYnNoQ8+A/vcyv6yVwEcDbMNZpXBBHBhf
+T3Q9rUSq5Mkli1t6aAKJA2XoxVL94V6KrUGSFqduim7w+p7WhfjYGKwRAf9SSGjX
+Xa36BhCQIOFmpMayiHpo5rRMexYNjQHyOjggND7BZqgh1eOHOw1E6SvYEqp4zEIh
+BJFUJiQgatZ39naQ/gWP7U1zm7LcbHAJnDO90PhihV8B8wCbakr1F3tmU4t+rzC5
+aIaTXNth4m/czrA0l/m9aQY10ccK9HqAo631rPz0+7lK6IPllK56BRTwZkJOX+Ii
+0nle0b7K0JqzbkwPr+BX+A09KWH3ElFWScfh+6AQDay7JZdSL3qJVQkaxs5DYZKU
+jIiWcBjgw2Oyb1MdfEIIwkRgXSEIp4DlGdKEusDAtmLqOUy694CdQes0b5N3A4QO
+VYSOsY2BXvA2IU0CUXm9Ci+p9OseWeBvXwoULNPl9u1036ozCl64seO+osqPi90g
+h+Dodw7w5pW/1bnL1Zq9NO6eL4tBopn9ziTiyjysFaDYcC0FHJw=
+=Izfx
+-----END PGP SIGNATURE-----