summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Pshenichnyi2021-11-10 16:28:59 +0100
committerKirill Pshenichnyi2021-11-10 16:28:59 +0100
commite8f37f5a0e5585868eba1b164c2a5c6199e637ad (patch)
tree698d2da5c917d0cb33223495aa859b0f2584580d
downloadaur-e8f37f5a0e5585868eba1b164c2a5c6199e637ad.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de97886d42b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-lttb-git
+ pkgdesc = Numpy implementation of Steinarsson’s Largest-Triangle-Three-Buckets algorithm
+ pkgver = v0.3.1.r3.g9463159
+ pkgrel = 1
+ url = https://github.com/sveinn-steinarsson/flot-downsample
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-numpy>=1.1
+ provides = python-lttb
+ conflicts = python-lttb
+ source = git+https://git.sr.ht/~javiljoen/lttb-numpy
+ sha256sums = SKIP
+
+pkgname = python-lttb-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c41cc377979
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kirill Pshenichnyi <pshcyrill@mail.ru>
+# Contributor: Jack Viljoen <ack@javiljoen.net>
+
+pkgname=python-lttb-git
+_pkgname=lttb-numpy
+pkgver=v0.3.1.r3.g9463159
+pkgrel=1
+pkgdesc="Numpy implementation of Steinarsson’s Largest-Triangle-Three-Buckets algorithm"
+arch=('any')
+url="https://github.com/sveinn-steinarsson/flot-downsample"
+license=('MIT')
+depends=('python' 'python-numpy>=1.1')
+conflicts=('python-lttb')
+provides=('python-lttb')
+source=("git+https://git.sr.ht/~javiljoen/lttb-numpy")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root=$pkgdir/
+}