summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-18 15:03:10 +0100
committerAlexander F. Rødseth2019-03-18 15:03:10 +0100
commit9e5445627dd4cc93aa25cee3f220f649b81eb88b (patch)
treea3e525d988d71580a113f61d9625622c2a0385c8
parent7ea9ac48471c405c1c5777baa1847aae31b188f0 (diff)
downloadaur-9e5445627dd4cc93aa25cee3f220f649b81eb88b.tar.gz
Minor change
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adf599dea93b..60cca425b86d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,14 @@
pkgname=python-ludwig
pkgver=0.1.0
-pkgrel=3
+pkgrel=4
pkgdesc='Train and test deep learning models'
arch=(any)
url='https://github.com/uber/ludwig'
license=(MIT)
depends=(cython python-cloudpickle python-dask python-h5py python-matplotlib python-numpy python-pandas python-scipy python-scikit-learn python-tqdm python-tabulate python-tensorflow python-yaml python-pytest python-scikit-image python-seaborn python-spacy-en_core_web_sm 'python-spacy>=2.0')
+# python2-numba is requored for the check() function in python-sparse to pass
+depends+=(python2-numba)
makedepends=(git)
source=("git+https://github.com/uber/ludwig#tag=v$pkgver")
sha256sums=('SKIP')
@@ -21,7 +23,7 @@ package() {
cd ludwig
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- sed -i '/spacy/d' "$pkgdir/usr/lib/python"*"/site-packages/ludwig-$pkgver-*.egg-info/requires.txt"
+ find "$pkgdir" -name requires.txt -type f -exec sed -i '/spacy/d' {} \;
}
# vim: ts=2 sw=2 et: