summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-26 00:18:16 +0200
committerPellegrino Prevete2023-06-26 00:18:16 +0200
commit310f2661e4ca344562b63dcbc8ad604a677e7b9a (patch)
tree0d6800157bce5bde64209cd0528312136a761526
parent8634fac9363362ffbebe1a38625712deb0e5414c (diff)
downloadaur-310f2661e4ca344562b63dcbc8ad604a677e7b9a.tar.gz
upgrade to 2.02.188
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD59
2 files changed, 49 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9de877d306bf..e403312f9f53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
-# Generated by mksrcinfo v8
-# Fri Aug 30 23:07:55 UTC 2019
pkgbase = python-lvm
pkgdesc = Python 3 bindings for LVM
- pkgver = 2.02.186
+ pkgver = 2.02.188
pkgrel = 1
url = http://sourceware.org/lvm2/
- arch = i686
arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = aarch64
+ arch = armv7h
license = LGPL2.1
depends = python
depends = lvm2
- source = https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.2.02.186.tgz
- source = https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.2.02.186.tgz.asc
- sha256sums = d8421eee702982dc0d8b0c9e40cc1443ee487eff1460a00244a9f4bf439a27be
+ source = https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.2.02.188.tgz
+ source = https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.2.02.188.tgz.asc
+ validpgpkeys = 88437EF5C077BD113D3B7224228191C1567E2C17
+ validpgpkeys = D501A478440AE2FD130A1BE8B9112431E509039F
+ sha256sums = 7101e8b0816ad77e4390fed9749a090214ba520061cd083437871e19e50cc9bd
sha256sums = SKIP
pkgname = python-lvm
-
diff --git a/PKGBUILD b/PKGBUILD
index 3aa492f1485a..a370497872c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,53 @@
-# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
-# Based on the lvm2 package in [core]
-pkgname="python-lvm"
-pkgver=2.02.186
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete at gmail dot com>
+# Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+
+_py="python"
+_pkg="lvm"
+pkgname="${_py}-${_pkg}"
+pkgver=2.02.188
pkgrel=1
-arch=('i686' 'x86_64')
-url="http://sourceware.org/lvm2/"
+arch=(
+ x86_64
+ i686
+ pentium4
+ aarch64
+ armv7h)
+url="http://sourceware.org/${_pkg}2/"
license=('LGPL2.1')
pkgdesc="Python 3 bindings for LVM"
-depends=('python' 'lvm2')
-source=("https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.${pkgver}.tgz"{,.asc})
-sha256sums=('d8421eee702982dc0d8b0c9e40cc1443ee487eff1460a00244a9f4bf439a27be'
- 'SKIP')
-validpgpkeys=('88437EF5C077BD113D3B7224228191C1567E2C17' # Alasdair G Kergon <agk@redhat.com>
- 'D501A478440AE2FD130A1BE8B9112431E509039F') # Marian Csontos <mcsontos@redhat.com>
+depends=("${_py}" "${_pkg}2")
+_url="https://ftp.gwdg.de/pub/linux/sources.redhat.com"
+source=("${_url}/${_pkg}2/LVM2.${pkgver}.tgz"{,.asc})
+sha256sums=(
+ '7101e8b0816ad77e4390fed9749a090214ba520061cd083437871e19e50cc9bd'
+ 'SKIP')
+validpgpkeys=(
+ '88437EF5C077BD113D3B7224228191C1567E2C17' # Alasdair G Kergon <agk@redhat.com>
+ 'D501A478440AE2FD130A1BE8B9112431E509039F') # Marian Csontos <mcsontos@redhat.com>
build() {
- local _CONFIGUREOPTS="--prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin \
- --with-udev-prefix=/usr --with-systemdsystemunitdir=/usr/lib/systemd/system \
- --with-default-pid-dir=/run --with-default-dm-run-dir=/run --with-default-run-dir=/run/lvm \
- --with-default-locking-dir=/run/lock/lvm \
- --enable-applib --enable-python3_bindings"
+ local _configure_opts=(
+ '--prefix=/usr'
+ '--sysconfdir=/etc'
+ '--localstatedir=/var'
+ '--sbindir=/usr/bin'
+ '--with-udev-prefix=/usr'
+ '--with-systemdsystemunitdir=/usr/lib/systemd/system'
+ '--with-default-pid-dir=/run'
+ '--with-default-dm-run-dir=/run'
+ '--with-default-run-dir=/run/lvm'
+ '--with-default-locking-dir=/run/lock/lvm'
+ '--enable-applib'
+ '--enable-python3_bindings')
- cd LVM2.${pkgver}
+ cd "LVM2.${pkgver}"
- ./configure ${_CONFIGUREOPTS}
+ ./configure "${_configure_opts[@]}"
make python
}
package() {
- cd LVM2.${pkgver}
+ cd "LVM2.${pkgver}"
make -C python DESTDIR="${pkgdir}" install
}