summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario O.M2019-08-18 19:33:51 +0200
committerMario O.M2019-08-18 19:33:51 +0200
commitebb0e9068982f8af181ada76449a94dd0bc60d0a (patch)
tree6fc131f6e8caf25707c7dd888b7ba5cbd53160ec
parent2d46a4e4def7550f5ecc0b379c7b7c3c8aab0465 (diff)
downloadaur-ebb0e9068982f8af181ada76449a94dd0bc60d0a.tar.gz
Small fixes and License
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d1196f73337..3ed1380dddf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = python-lyricwikia
pkgrel = 1
url = http://github.com/enricobacis/lyricwikia
arch = any
- license = MIT
+ license = custom:MIT
makedepends = python-setuptools
depends = python
depends = python-six
diff --git a/PKGBUILD b/PKGBUILD
index 8f7a976199d4..48ba0783aa55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,19 @@ pkgrel=1
pkgdesc="LyricWikia API for song lyrics"
arch=("any")
url="http://github.com/enricobacis/lyricwikia"
-license=("MIT")
+license=("custom:MIT")
depends=("python" "python-six" "python-requests" "python-beautifulsoup4")
makedepends=("python-setuptools")
source=("https://github.com/enricobacis/lyricwikia/archive/${pkgver}.tar.gz")
md5sums=('38cf496f85110964fb303cfa8a4aa26b')
build() {
- cd $srcdir/lyricwikia-$pkgver
+ cd "lyricwikia-$pkgver"
python setup.py build
}
package() {
- cd $srcdir/lyricwikia-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "lyricwikia-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}