summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-19 18:01:38 -0500
committerclintval2017-12-19 18:01:38 -0500
commit3a4f1adef72e4d00e4e3d18ffa24c619b4544394 (patch)
treeb4f1f2f300703656e38321474dc4872e71799c3e
downloadaur-3a4f1adef72e4d00e4e3d18ffa24c619b4544394.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80905dab2b5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-lzstring
+ pkgdesc = LZ-string compression for Python
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/lzstring/
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-lzstring
+ conflicts = python-lzstring
+ options = !emptydirs
+ source = https://pypi.python.org/packages/2b/e0/06231b1114cae946b6d3505ab8157f7308b207e3f8e3eb58334769dab6c0/lzstring-1.0.3.tar.gz
+ md5sums = 1c636543484629020a26432740f81443
+
+pkgname = python-lzstring
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c248e00691da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-lzstring'
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="LZ-string compression for Python"
+arch=('x86_64')
+url="https://pypi.python.org/pypi/lzstring/"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+provides=('python-lzstring')
+conflicts=('python-lzstring')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/2b/e0/06231b1114cae946b6d3505ab8157f7308b207e3f8e3eb58334769dab6c0/lzstring-${pkgver}.tar.gz")
+md5sums=('1c636543484629020a26432740f81443')
+
+package() {
+ cd "${srcdir}/lzstring-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}