summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Chapuis2019-04-04 10:25:39 +0200
committerPierre Chapuis2019-04-04 10:25:39 +0200
commitc96c2dd01f8190e80aa6f67617f964ee26b01363 (patch)
tree14b5f9969078b33cb5cfa07db0b2afb38058939b
downloadaur-c96c2dd01f8190e80aa6f67617f964ee26b01363.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE.txt21
-rw-r--r--PKGBUILD48
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bf2b87fc390
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-mailjet
+ pkgdesc = Official Mailjet Python Wrapper
+ pkgver = 1.3.3
+ pkgrel = 1
+ url = https://pypi.org/project/mailjet-rest/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = python-requests
+ makedepends = python2-requests
+ source = https://files.pythonhosted.org/packages/69/04/a92885c635ca412c8f5bdf3d11da6f619bbd4bce45c4e28189eeef10bd6a/mailjet_rest-1.3.3.tar.gz
+ source = LICENSE.txt
+ sha256sums = f14424df10c30083491dcaa5902ff9b159af82bca261af5e7b2213afdcf7a11c
+ sha256sums = 104cc6b013a00cb45959c7caa51e996f5b782cfffb7995eb57ebf44147194674
+
+pkgname = python-mailjet
+ depends = python-requests
+
+pkgname = python2-mailjet
+ depends = python2-requests
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..f44502d03556
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 starenka
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a9f6905faa4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Pierre Chapuis <catwell@archlinux.us>
+
+pkgname=("python-mailjet" "python2-mailjet")
+pkgver=1.3.3
+pkgrel=1
+pkgdesc="Official Mailjet Python Wrapper"
+arch=("any")
+url="https://pypi.org/project/mailjet-rest/"
+license=("MIT")
+makedepends=(
+ "python-setuptools" "python2-setuptools"
+ "python-requests" "python2-requests"
+)
+source=(
+ "https://files.pythonhosted.org/packages/69/04/a92885c635ca412c8f5bdf3d11da6f619bbd4bce45c4e28189eeef10bd6a/mailjet_rest-$pkgver.tar.gz"
+ "LICENSE.txt"
+)
+sha256sums=(
+ "f14424df10c30083491dcaa5902ff9b159af82bca261af5e7b2213afdcf7a11c"
+ "104cc6b013a00cb45959c7caa51e996f5b782cfffb7995eb57ebf44147194674"
+)
+
+build() {
+ cd "$srcdir"
+ rm -rf python{2,3}-build
+ for builddir in python{2,3}-build; do
+ cp -r "mailjet_rest-$pkgver" "$builddir"
+ pushd "$builddir"
+ "${builddir%-build}" setup.py build
+ popd
+ done
+}
+
+package_python-mailjet() {
+ depends=("python-requests")
+ cd "$srcdir/python3-build"
+ python3 setup.py install --root="$pkgdir" -O1
+ install -Dm644 "$srcdir/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-mailjet() {
+ depends=("python2-requests")
+ cd "$srcdir/python2-build"
+ python2 setup.py install --root="$pkgdir" -O1
+ install -Dm644 "$srcdir/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}