summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2017-03-09 16:20:58 +0100
committerChristopher Arndt2017-03-09 16:20:58 +0100
commit1e03ff580ac4f4cb84a1bc008baad540cc0da333 (patch)
tree23628b0603d4933adc817e704e1771e9e927a291
parent53bee2cbf928a97d2223121f607b4ffac2b38c68 (diff)
downloadaur-1e03ff580ac4f4cb84a1bc008baad540cc0da333.tar.gz
New upstream version; PKGBUILD tweaks; make python-sphinx dependency optional
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c64f2eff9a9..4162629727b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
# Generated by mksrcinfo v8
-# Fri Oct 21 15:07:34 UTC 2016
+# Thu Mar 9 15:19:40 UTC 2017
pkgbase = python-mando
- pkgver = 0.4
- pkgrel = 2
+ pkgver = 0.5
+ pkgrel = 1
url = https://mando.readthedocs.org/
arch = any
license = MIT
- source = https://pypi.python.org/packages/2b/52/684d9ab8c2ccfb611275f2e44d3ebc76a6a6c56f4afacd2e91237fa07ec3/mando-0.4.tar.gz
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/m/mando/mando-0.5.tar.gz
source = LICENSE
- sha256sums = 853ff98f80266387b37850ecc4f8cac59d24cecc623fb7d2ef2bc5febbad2cae
+ sha256sums = 80b5b5f0405e64d8b35ae04c5e897ecdfdcc7337154b32696df8a5418c810560
sha256sums = 6123bc92c70372634b45af73fbae39eaa70683a66782b73b833c258c4de939eb
pkgname = python-mando
pkgdesc = Python library which wraps the argparse module to help write flexible CLI applications
- depends = python-sphinx
+ depends = python
+ optdepends = python-sphinx: to run unit tests
pkgname = python2-mando
pkgdesc = Python 2 library which wraps the argparse module to help write flexible CLI applications
- depends = python2-sphinx
+ depends = python2
+ optdepends = python2-sphinx: to run unit tests
diff --git a/PKGBUILD b/PKGBUILD
index 2c4ffc1c4f6a..8918ddba8d1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Christopher Arndt <aur at chrisarndt dot de>
-_module="mando"
-pkgbase="python-${_module}"
-pkgname=("${pkgbase}" "python2-${_module}")
-pkgver=0.4
-pkgrel=2
+_name="mando"
+pkgbase="python-${_name}"
+pkgname=("${pkgbase}" "python2-${_name}")
+pkgver=0.5
+pkgrel=1
arch=('any')
-url="https://mando.readthedocs.org/"
+url="https://${_name}.readthedocs.org/"
+# Repository: https://github.com/rubik/mando
license=('MIT')
depends=()
-source=("https://pypi.python.org/packages/2b/52/684d9ab8c2ccfb611275f2e44d3ebc76a6a6c56f4afacd2e91237fa07ec3/${_module}-${pkgver}.tar.gz"
- 'LICENSE'
-)
-sha256sums=('853ff98f80266387b37850ecc4f8cac59d24cecc623fb7d2ef2bc5febbad2cae'
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('80b5b5f0405e64d8b35ae04c5e897ecdfdcc7337154b32696df8a5418c810560'
'6123bc92c70372634b45af73fbae39eaa70683a66782b73b833c258c4de939eb')
prepare() {
- cp -r ${_module}-${pkgver} python2-${_module}-${pkgver}
+ cp -r ${_name}-${pkgver} python2-${_name}-${pkgver}
}
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
- cd "${srcdir}/python2-${_module}-${pkgver}"
+ cd "${srcdir}/python2-${_name}-${pkgver}"
for script in capture.py run.py; do
sed -i -e 's|python|python2|' mando/tests/${script}
done
@@ -32,9 +33,10 @@ build() {
package_python-mando() {
pkgdesc="Python library which wraps the argparse module to help write flexible CLI applications"
- depends=('python-sphinx')
+ depends=('python')
+ optdepends=('python-sphinx: to run unit tests')
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="$pkgdir" --skip-build --optimize=1
# license
@@ -43,9 +45,10 @@ package_python-mando() {
package_python2-mando() {
pkgdesc="Python 2 library which wraps the argparse module to help write flexible CLI applications"
- depends=('python2-sphinx')
+ depends=('python2')
+ optdepends=('python2-sphinx: to run unit tests')
- cd "${srcdir}/python2-${_module}-$pkgver"
+ cd "${srcdir}/python2-${_name}-$pkgver"
python2 setup.py install --root="$pkgdir" --skip-build --optimize=1
# license