summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-11-24 19:13:43 +0100
committerChristopher Arndt2019-11-24 19:13:43 +0100
commit696ca0d670c44e829b1f5a31ff08c67d2cf6a15b (patch)
tree720da4705d23e72313870977528e4edeb1c69ffd
parent2bcc602011ae3b9895b9fb0d3acb8b89ed0a2108 (diff)
downloadaur-696ca0d670c44e829b1f5a31ff08c67d2cf6a15b.tar.gz
* Increase revision to trigger package rebuild for Python 3.8
* Remove Python 2 package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 10 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9df4d57866af..59b518e03207 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,17 @@
-# Generated by mksrcinfo v8
-# Thu Jun 15 16:34:49 UTC 2017
pkgbase = python-mando
+ pkgdesc = Python library which wraps the argparse module to help write flexible CLI applications
pkgver = 0.6.4
- pkgrel = 1
+ pkgrel = 2
url = https://mando.readthedocs.org/
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python2-setuptools
+ depends = python
+ optdepends = python-sphinx: to run unit tests
source = https://files.pythonhosted.org/packages/source/m/mando/mando-0.6.4.tar.gz
source = LICENSE
sha256sums = 79feb19dc0f097daa64a1243db578e7674909b75f88ac2220f1c065c10a0d960
sha256sums = 6123bc92c70372634b45af73fbae39eaa70683a66782b73b833c258c4de939eb
pkgname = python-mando
- pkgdesc = Python library which wraps the argparse module to help write flexible CLI applications
- depends = python
- optdepends = python-sphinx: to run unit tests
-
-pkgname = python2-mando
- pkgdesc = Python 2 library which wraps the argparse module to help write flexible CLI applications
- depends = python2
- optdepends = python2-sphinx: to run unit tests
diff --git a/PKGBUILD b/PKGBUILD
index 5cc6aa79711d..0d66fde1304c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,28 @@
# Maintainer: Christopher Arndt <aur at chrisarndt dot de>
_name="mando"
-pkgbase="python-${_name}"
-pkgname=("${pkgbase}" "python2-${_name}")
+pkgname="python-${_name}"
pkgver=0.6.4
-pkgrel=1
+pkgrel=2
+pkgdesc="Python library which wraps the argparse module to help write flexible CLI applications"
arch=('any')
url="https://${_name}.readthedocs.org/"
# Repository: https://github.com/rubik/mando
license=('MIT')
-depends=()
-makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python')
+optdepends=('python-sphinx: to run unit tests')
+makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
'LICENSE')
sha256sums=('79feb19dc0f097daa64a1243db578e7674909b75f88ac2220f1c065c10a0d960'
'6123bc92c70372634b45af73fbae39eaa70683a66782b73b833c258c4de939eb')
-prepare() {
- cp -r ${_name}-${pkgver} python2-${_name}-${pkgver}
-}
-
build() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
-
- cd "${srcdir}/python2-${_name}-${pkgver}"
- for script in capture.py run.py; do
- sed -i -e 's|python|python2|' mando/tests/${script}
- done
- python2 setup.py build
}
package_python-mando() {
- pkgdesc="Python library which wraps the argparse module to help write flexible CLI applications"
- depends=('python')
- optdepends=('python-sphinx: to run unit tests')
-
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="$pkgdir" --skip-build --optimize=1
@@ -43,16 +30,4 @@ package_python-mando() {
install -Dm644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-package_python2-mando() {
- pkgdesc="Python 2 library which wraps the argparse module to help write flexible CLI applications"
- depends=('python2')
- optdepends=('python2-sphinx: to run unit tests')
-
- cd "${srcdir}/python2-${_name}-$pkgver"
- python2 setup.py install --root="$pkgdir" --skip-build --optimize=1
-
- # license
- install -Dm644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
# vim:set ts=2 sw=2 et: