summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2015-11-22 14:17:32 +0100
committerChristopher Arndt2015-11-22 14:17:32 +0100
commit8438b33f5b5c6e89cfe13c6a4900450aba902a18 (patch)
tree00c9b9638429150a0d6a9e243d90c073659404be
downloadaur-8438b33f5b5c6e89cfe13c6a4900450aba902a18.tar.gz
Add new package python-mando
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD19
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fea6dec6a87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-mando
+ pkgdesc = A wrapper for the Python argparse module, which helps to write flexible CLI applications
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://mando.readthedocs.org/
+ arch = any
+ license = MIT
+ depends = python
+ source = http://pypi.python.org/packages/source/m/mando/mando-0.3.3.tar.gz
+ md5sums = 4244d87684a3c49b888dc702589a7d5b
+
+pkgname = python-mando
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ac25ff89f53a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg
+src
+mando-*.tar.gz
+python-mando-*.pkg.tar.xz
+python-mando-*.src.tar.gz
+.AURINFO
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9702a7dc5c7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Christopher Arndt <aur at chrisarndt dot de>
+
+pkgname=python-mando
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="A wrapper for the Python argparse module, which helps to write flexible CLI applications"
+arch=('any')
+url="https://mando.readthedocs.org/"
+license=('MIT')
+depends=('python')
+source=("http://pypi.python.org/packages/source/m/mando/mando-${pkgver}.tar.gz")
+md5sums=('4244d87684a3c49b888dc702589a7d5b')
+
+package() {
+ cd "$srcdir/mando-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: