summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-05-12 01:22:54 +0200
committerChristopher Arndt2023-05-12 01:24:34 +0200
commitc119c3cb034184dffaf4ff369cab470f5ea3e3ba (patch)
tree847aa9a8e7b9782e6179f0596911a651e10bc6dd
parent6cbcda1e22f2a05c72f158908f7cc813872766f2 (diff)
downloadaur-c119c3cb034184dffaf4ff369cab470f5ea3e3ba.tar.gz
New upstream version 0.7.1
Updated to PEP-517 compliant build Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD40
3 files changed, 32 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1015f8c32336..033dbb1473fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = python-mando
- pkgdesc = Python library which wraps the argparse module to help write flexible CLI applications
- pkgver = 0.7.0
+ pkgdesc = Python library wrapping argparse to help write flexible CLI applications
+ pkgver = 0.7.1
pkgrel = 2
url = https://mando.readthedocs.org/
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-rst2ansi
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
- optdepends = python-rst2ansi: restructuredText support
- source = https://files.pythonhosted.org/packages/source/m/mando/mando-0.7.0.tar.gz
- source = LICENSE
- sha256sums = 5306a91109096fe2e204a1f5ae141038842193f7210a7930c8ee73ccb7ecbf62
- sha256sums = 6123bc92c70372634b45af73fbae39eaa70683a66782b73b833c258c4de939eb
+ optdepends = python-rst2ansi: ReST formatting of console help output
+ optdepends = python-sphinx: run unit tests
+ source = https://files.pythonhosted.org/packages/source/m/mando/mando-0.7.1.tar.gz
+ sha256sums = 18baa999b4b613faefb00eac4efadcf14f510b59b924b66e08289aa1de8c3500
pkgname = python-mando
diff --git a/.gitignore b/.gitignore
index 0e54645902a7..c99fcf3136b9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,5 @@
-pkg
-src
+pkg/
+src/
mando-*.tar.gz
-python-mando-*.pkg.tar.xz
-python-mando-*.pkg.tar.zst
+python-mando-*.pkg.tar.*
python-mando-*.src.tar.gz
-.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
index 045c71c811c2..bef269ccdbdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
# Maintainer: Christopher Arndt <aur at chrisarndt dot de>
-_name="mando"
-pkgname="python-${_name}"
-pkgver=0.7.0
+_name=mando
+pkgname=python-$_name
+pkgver=0.7.1
pkgrel=2
-pkgdesc="Python library which wraps the argparse module to help write flexible CLI applications"
-arch=('any')
-url="https://${_name}.readthedocs.org/"
+pkgdesc='Python library wrapping argparse to help write flexible CLI applications'
+arch=(any)
+url='https://mando.readthedocs.org/'
# Repository: https://github.com/rubik/mando
-license=('MIT')
-depends=('python')
-optdepends=('python-sphinx: to run unit tests')
-makedepends=('python-rst2ansi' 'python-setuptools')
-optdepends=('python-rst2ansi: restructuredText support')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- 'LICENSE')
-sha256sums=('5306a91109096fe2e204a1f5ae141038842193f7210a7930c8ee73ccb7ecbf62'
- '6123bc92c70372634b45af73fbae39eaa70683a66782b73b833c258c4de939eb')
+license=(MIT)
+depends=(python)
+optdepends=(
+ 'python-rst2ansi: ReST formatting of console help output'
+ 'python-sphinx: run unit tests'
+)
+makedepends=(python-build python-installer python-rst2ansi python-setuptools python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('18baa999b4b613faefb00eac4efadcf14f510b59b924b66e08289aa1de8c3500')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py build
+ cd $_name-$pkgver
+ python -m build --wheel --no-isolation
}
package_python-mando() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="$pkgdir" --skip-build --optimize=1
+ cd $_name-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
# license
- install -Dm644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}
# vim:set ts=2 sw=2 et: