summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-10-15 14:25:54 +0200
committerChristopher Arndt2016-10-15 14:25:54 +0200
commitf7d974f02420c040171fa66f9e0edfa7ca0a99f6 (patch)
treeb7ef6826e8b137ce4ae5ec135df620a176ed63ff
parent8438b33f5b5c6e89cfe13c6a4900450aba902a18 (diff)
downloadaur-f7d974f02420c040171fa66f9e0edfa7ca0a99f6.tar.gz
New upstream version 0.4; added python-sphinx dependency, added LICENSE file
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD19
3 files changed, 43 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fea6dec6a87..bed2df65434d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Oct 15 12:24:47 UTC 2016
pkgbase = python-mando
pkgdesc = A wrapper for the Python argparse module, which helps to write flexible CLI applications
- pkgver = 0.3.3
+ pkgver = 0.4
pkgrel = 1
url = https://mando.readthedocs.org/
arch = any
license = MIT
- depends = python
- source = http://pypi.python.org/packages/source/m/mando/mando-0.3.3.tar.gz
- md5sums = 4244d87684a3c49b888dc702589a7d5b
+ depends = python-sphinx
+ source = https://pypi.python.org/packages/2b/52/684d9ab8c2ccfb611275f2e44d3ebc76a6a6c56f4afacd2e91237fa07ec3/mando-0.4.tar.gz
+ source = LICENSE
+ sha256sums = 853ff98f80266387b37850ecc4f8cac59d24cecc623fb7d2ef2bc5febbad2cae
+ sha256sums = 6123bc92c70372634b45af73fbae39eaa70683a66782b73b833c258c4de939eb
pkgname = python-mando
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..481337e2b660
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2016 Michele Lacchia
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
index 9702a7dc5c7d..dadb2cb7c672 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Maintainer: Christopher Arndt <aur at chrisarndt dot de>
-pkgname=python-mando
-pkgver=0.3.3
+_pkgname="mando"
+pkgname="python-${_pkgname}"
+pkgver=0.4
pkgrel=1
pkgdesc="A wrapper for the Python argparse module, which helps to write flexible CLI applications"
arch=('any')
url="https://mando.readthedocs.org/"
license=('MIT')
-depends=('python')
-source=("http://pypi.python.org/packages/source/m/mando/mando-${pkgver}.tar.gz")
-md5sums=('4244d87684a3c49b888dc702589a7d5b')
+depends=('python-sphinx')
+source=("https://pypi.python.org/packages/2b/52/684d9ab8c2ccfb611275f2e44d3ebc76a6a6c56f4afacd2e91237fa07ec3/${_pkgname}-${pkgver}.tar.gz"
+ 'LICENSE'
+)
+sha256sums=('853ff98f80266387b37850ecc4f8cac59d24cecc623fb7d2ef2bc5febbad2cae'
+ '6123bc92c70372634b45af73fbae39eaa70683a66782b73b833c258c4de939eb')
package() {
- cd "$srcdir/mando-$pkgver"
+ cd "$srcdir/${_pkgname}-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+
+ # license
+ install -Dm644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: