summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGroctel2021-01-05 15:42:08 +0100
committerGroctel2021-01-05 15:42:08 +0100
commit6777ed354e0221f9eb1e1d4f6da7e5d4eaa7a691 (patch)
tree4eb9502fae551b5525b974f4f8c9338d77565350
downloadaur-6777ed354e0221f9eb1e1d4f6da7e5d4eaa7a691.tar.gz
First AUR release commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb6be30015a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-manimpango
+ pkgdesc = C binding for Pango using Cython used in Manim to render (non-LaTeX) text.
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/ManimCommunity/manimpango/
+ arch = any
+ license = GPL3
+ depends = pango
+ depends = python
+ source = https://github.com/ManimCommunity/ManimPango/releases/download/v0.1.4/manimpango-0.1.4.tar.gz
+ sha256sums = 693fbc52ea60c75acb9c98f23fc8e98a429b5ce02ab761ef9db24e9d61d62a49
+
+pkgname = manimpango
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..873440b7885e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Groctel <aur@taxorubio.com>
+pkgbase=python-manimpango
+pkgname=manimpango
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="C binding for Pango using Cython used in Manim to render (non-LaTeX) text."
+arch=('any')
+url="https://github.com/ManimCommunity/manimpango/"
+license=('GPL3')
+depends=(
+ 'pango'
+ 'python'
+)
+makedepends=(
+ 'python-setuptools'
+)
+provides=()
+source=("https://github.com/ManimCommunity/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('693fbc52ea60c75acb9c98f23fc8e98a429b5ce02ab761ef9db24e9d61d62a49')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}