summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGroctel2021-01-05 15:52:02 +0100
committerGroctel2021-01-05 15:52:47 +0100
commit7d29ce06b2b8260f916678fda375933946532a4b (patch)
tree7f0d3a98821d0c84e8820afb50fe7bcc0d3be0c3
parent6777ed354e0221f9eb1e1d4f6da7e5d4eaa7a691 (diff)
downloadaur-7d29ce06b2b8260f916678fda375933946532a4b.tar.gz
Fixed package name
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb6be30015a7..49931d297637 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,11 @@ pkgbase = python-manimpango
url = https://github.com/ManimCommunity/manimpango/
arch = any
license = GPL3
+ makedepends = python-setuptools
depends = pango
depends = python
- source = https://github.com/ManimCommunity/ManimPango/releases/download/v0.1.4/manimpango-0.1.4.tar.gz
+ source = https://github.com/ManimCommunity/manimpango/releases/download/v0.1.4/manimpango-0.1.4.tar.gz
sha256sums = 693fbc52ea60c75acb9c98f23fc8e98a429b5ce02ab761ef9db24e9d61d62a49
-pkgname = manimpango
+pkgname = python-manimpango
diff --git a/PKGBUILD b/PKGBUILD
index 873440b7885e..2770223cd988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Groctel <aur@taxorubio.com>
-pkgbase=python-manimpango
-pkgname=manimpango
+pkgname=python-manimpango
+_name=${pkgname#python-}
pkgver=0.1.4
pkgrel=1
pkgdesc="C binding for Pango using Cython used in Manim to render (non-LaTeX) text."
@@ -15,16 +15,16 @@ makedepends=(
'python-setuptools'
)
provides=()
-source=("https://github.com/ManimCommunity/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+source=("https://github.com/ManimCommunity/$_name/releases/download/v$pkgver/$_name-$pkgver.tar.gz")
sha256sums=('693fbc52ea60c75acb9c98f23fc8e98a429b5ce02ab761ef9db24e9d61d62a49')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_name/LICENSE"
}