summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-07-28 10:09:53 +0800
committerPumpkinCheshire2021-07-28 10:09:53 +0800
commit85ffd9baf58e4d35c5c21076958bd37191a5d05b (patch)
tree74de3196c7b0ef785a29e195265f168ac2429adc
parent26efefdf0606f115e635c784279207f8bf1d4076 (diff)
downloadaur-python-mapclassify.tar.gz
bump to 2.4.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c817a81f6460..238af8ab90d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-mapclassify
pkgdesc = Classification schemes for choropleth mapping.
- pkgver = 2.4.2
+ pkgver = 2.4.3
pkgrel = 1
url = https://github.com/pysal/mapclassify
arch = any
@@ -22,8 +22,7 @@ pkgbase = python-mapclassify
optdepends = python-geopandas: tests
optdepends = python-libpysal: tests
optdepends = python-palettable: tests
- source = https://files.pythonhosted.org/packages/source/m/mapclassify/mapclassify-2.4.2.tar.gz
- sha256sums = bc20954aa433466f5fbc572e3f23b05f9606b59209f40b0ded93ac1ca983d24e
+ source = https://files.pythonhosted.org/packages/source/m/mapclassify/mapclassify-2.4.3.tar.gz
+ b2sums = 227465a610d90a6a78d4eebdfebe19433bca5262c843169d53c11be8603ab27ba9957170327ed2c861c5a859cdb5169600f6566723a592fb5a702488be57d0f6
pkgname = python-mapclassify
-
diff --git a/PKGBUILD b/PKGBUILD
index 7d48c6f3d4c8..9c6abff77a0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,24 @@
-# Maintainer: PumpkinCheshire <sollyonzou@gmail.com>
+#!/bin/bash
+
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
_name=mapclassify
pkgname=python-mapclassify
-pkgver=2.4.2
+pkgver=2.4.3
pkgrel=1
-pkgdesc="Classification schemes for choropleth mapping."
+pkgdesc='Classification schemes for choropleth mapping.'
+url='https://github.com/pysal/mapclassify'
arch=('any')
-url="https://github.com/pysal/mapclassify"
license=('BSD')
-depends=('python-scipy' 'python-numpy' 'python-scikit-learn' 'python-pandas' 'python-networkx')
-optdepends=('python-sphinx: documents'
+depends=(
+ 'python-scipy'
+ 'python-numpy'
+ 'python-scikit-learn'
+ 'python-pandas'
+ 'python-networkx'
+)
+optdepends=(
+ 'python-sphinx: documents'
'python-sphinx-gallery: documents'
'python-sphinx-bootstrap-theme: documents'
'python-sphinxcontrib-bibtex: documents'
@@ -19,18 +28,20 @@ optdepends=('python-sphinx: documents'
'python-codecov: tests'
'python-geopandas: tests'
'python-libpysal: tests'
- 'python-palettable: tests')
+ 'python-palettable: tests'
+)
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('bc20954aa433466f5fbc572e3f23b05f9606b59209f40b0ded93ac1ca983d24e')
+b2sums=('227465a610d90a6a78d4eebdfebe19433bca5262c843169d53c11be8603ab27ba9957170327ed2c861c5a859cdb5169600f6566723a592fb5a702488be57d0f6')
build() {
- cd "$_name-$pkgver"
+ cd "$_name-$pkgver" || exit
+ export PYTHONHASHSEED=0
python setup.py build
}
package() {
- cd "$_name-$pkgver"
+ cd "$_name-$pkgver" || exit
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 'LICENSE.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}