summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Kazimiers2023-12-04 16:04:10 +0100
committerTom Kazimiers2023-12-04 16:04:10 +0100
commit1afa2b6bcb65d4174b01891a6fda84b1fce89ac0 (patch)
treec2f6bcf516fff3c753dc02d925ceb1f072f78e67
parente5c6e0c2c1ec501683d90a09fc066f5fd0100d01 (diff)
downloadaur-python-mapnik.tar.gz
Fix compilation errror with Proj6 API ptch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--proj6-apis.patch88
3 files changed, 2 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 827d5447fe35..523e9fc89ea2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-mapnik
pkgdesc = Python3 bindings for Mapnik
pkgver = 3.0.16
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/mapnik/python-mapnik
arch = any
license = LGPL
diff --git a/PKGBUILD b/PKGBUILD
index fc252a1444d2..8ada151be093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-mapnik
pkgver=3.0.16
-pkgrel=3
+pkgrel=4
pkgdesc="Python3 bindings for Mapnik"
url="https://github.com/mapnik/python-mapnik"
@@ -15,13 +15,11 @@ makedepends=('python-setuptools')
source=("https://github.com/mapnik/python-mapnik/archive/v$pkgver.tar.gz"
"package.patch"
- "proj6-apis.patch"
"proj6-syntax.patch"
"no-distutils.patch"
"boost1.71.patch")
sha1sums=('8e30049954b14282667677a5d5a145eddedfc8df'
'b85f58f54a3353fbb51df79ea4d337f3b299cac7'
- 'da86ea6a077a0eee051342a8ac8dab72a3f0b5c0'
'bf4118f8770c8a6ebfe144fbd8293c461de63ac8'
'57272b7d7424c9f1b9650305738f46dd1d757348'
'3a595137ebf04e96b18b672ce1aa0e20bcb72ee2')
@@ -30,7 +28,6 @@ prepare() {
cd "$pkgname-$pkgver"
rm "src/mapnik_svg_generator_grammar.cpp"
patch --forward --strip=1 --input="${srcdir}/package.patch"
- patch --forward --strip=1 --input="${srcdir}/proj6-apis.patch"
patch --forward --strip=1 --input="${srcdir}/proj6-syntax.patch"
patch --forward --strip=1 --input="${srcdir}/no-distutils.patch"
patch --forward --strip=1 --input="${srcdir}/boost1.71.patch"
diff --git a/proj6-apis.patch b/proj6-apis.patch
deleted file mode 100644
index b645e692a8c3..000000000000
--- a/proj6-apis.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-Description: Upgrade to use new APIs
-Author: Artem Pavlenko <artem@mapnik.org>
-Origin: https://github.com/mapnik/python-mapnik/commit/feec9afa66131b074c40359529e498eab0d79a02
-Forwarded: not-needed
-
---- a/src/mapnik_proj_transform.cpp
-+++ b/src/mapnik_proj_transform.cpp
-@@ -48,7 +48,7 @@ struct proj_transform_pickle_suite : boo
- getinitargs(const proj_transform& p)
- {
- using namespace boost::python;
-- return boost::python::make_tuple(p.source(),p.dest());
-+ return boost::python::make_tuple(p.definition());
- }
- };
-
-@@ -62,7 +62,7 @@ mapnik::coord2d forward_transform_c(mapn
- if (!t.forward(x,y,z)) {
- std::ostringstream s;
- s << "Failed to forward project "
-- << "from " << t.source().params() << " to: " << t.dest().params();
-+ << t.definition();
- throw std::runtime_error(s.str());
- }
- return mapnik::coord2d(x,y);
-@@ -76,7 +76,7 @@ mapnik::coord2d backward_transform_c(map
- if (!t.backward(x,y,z)) {
- std::ostringstream s;
- s << "Failed to back project "
-- << "from " << t.dest().params() << " to: " << t.source().params();
-+ << t.definition();
- throw std::runtime_error(s.str());
- }
- return mapnik::coord2d(x,y);
-@@ -88,7 +88,7 @@ mapnik::box2d<double> forward_transform_
- if (!t.forward(new_box)) {
- std::ostringstream s;
- s << "Failed to forward project "
-- << "from " << t.source().params() << " to: " << t.dest().params();
-+ << t.definition();
- throw std::runtime_error(s.str());
- }
- return new_box;
-@@ -100,7 +100,7 @@ mapnik::box2d<double> backward_transform
- if (!t.backward(new_box)){
- std::ostringstream s;
- s << "Failed to back project "
-- << "from " << t.dest().params() << " to: " << t.source().params();
-+ << t.definition();
- throw std::runtime_error(s.str());
- }
- return new_box;
-@@ -112,7 +112,7 @@ mapnik::box2d<double> forward_transform_
- if (!t.forward(new_box,points)) {
- std::ostringstream s;
- s << "Failed to forward project "
-- << "from " << t.source().params() << " to: " << t.dest().params();
-+ << t.definition();
- throw std::runtime_error(s.str());
- }
- return new_box;
-@@ -124,7 +124,7 @@ mapnik::box2d<double> backward_transform
- if (!t.backward(new_box,points)){
- std::ostringstream s;
- s << "Failed to back project "
-- << "from " << t.dest().params() << " to: " << t.source().params();
-+ << t.definition();
- throw std::runtime_error(s.str());
- }
- return new_box;
-@@ -136,7 +136,7 @@ void export_proj_transform ()
- {
- using namespace boost::python;
-
-- class_<proj_transform, boost::noncopyable>("ProjTransform", init< projection const&, projection const& >())
-+ class_<proj_transform, boost::noncopyable>("ProjTransform", init<projection const&, projection const&>())
- .def_pickle(proj_transform_pickle_suite())
- .def("forward", forward_transform_c)
- .def("backward",backward_transform_c)
-@@ -144,6 +144,7 @@ void export_proj_transform ()
- .def("backward",backward_transform_env)
- .def("forward", forward_transform_env_p)
- .def("backward",backward_transform_env_p)
-+ .def("definition",&proj_transform::definition)
- ;
-
- }
-