summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChaosKid422016-04-25 18:12:22 +0200
committerChaosKid422016-04-25 18:12:22 +0200
commitf89f3632fff748e5fa0b0a03510c3f925ae341c0 (patch)
tree0c11355ef408792cf0393876ce7d810dbe96df09
parent5246664c0650cbec0595c5c6eb7897fc5f1ac38e (diff)
downloadaur-f89f3632fff748e5fa0b0a03510c3f925ae341c0.tar.gz
added optdepends
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0130796c9db1..d10553696e00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Apr 25 15:53:56 UTC 2016
+# Mon Apr 25 16:07:31 UTC 2016
pkgbase = python-mapproxy
pkgdesc = A tile cache and WMS proxy.
pkgver = 1.8.2
@@ -15,8 +15,18 @@ pkgbase = python-mapproxy
pkgname = python-mapproxy
depends = python
depends = python-pillow
+ depends = python-yaml
+ depends = python-pyproj
+ optdepends = python-shapely: coverage feature support
+ optdepends = python-gdal: OGR datasource support
+ optdepends = python-lxml: more advanced WMS FeatureInformation support
pkgname = python2-mapproxy
depends = python2
- depends = python-pillow
+ depends = python2-pillow
+ depends = python2-yaml
+ depends = python2-pyproj
+ optdepends = python2-shapely: coverage feature support
+ optdepends = python2-gdal: OGR datasource support
+ optdepends = python2-lxml: more advanced WMS FeatureInformation support
diff --git a/PKGBUILD b/PKGBUILD
index 09e3589d488c..71d8bfe69f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,13 +20,19 @@ build() {
}
package_python-mapproxy() {
-depends=('python' 'python-pillow')
+depends=('python' 'python-pillow' 'python-yaml' 'python-pyproj')
+optdepends=('python-shapely: coverage feature support'
+ 'python-gdal: OGR datasource support'
+ 'python-lxml: more advanced WMS FeatureInformation support')
cd $srcdir/mapproxy-${pkgver}
python setup.py install --root=$pkgdir/
}
package_python2-mapproxy() {
-depends=('python2' 'python-pillow')
+depends=('python2' 'python2-pillow' 'python2-yaml' 'python2-pyproj')
+optdepends=('python2-shapely: coverage feature support'
+ 'python2-gdal: OGR datasource support'
+ 'python2-lxml: more advanced WMS FeatureInformation support')
cd $srcdir/mapproxy2-${pkgver}
python2 setup.py install --root=$pkgdir/
}