summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-04-28 18:01:17 +0000
committerBioArchLinuxBot2023-04-28 18:01:17 +0000
commitb212626482c4ba186a57c3e0de8be3b8368188b2 (patch)
tree6438ebc58f3115a6fb0a38ccb6263c213a37a0c3
parent0629071fea6d6cb954b1a3be0d04867d40141299 (diff)
downloadaur-b212626482c4ba186a57c3e0de8be3b8368188b2.tar.gz
[lilac] updated to 2.25-4
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f1c325c93eb..610357bb973f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = python-mappy
pkgdesc = Python interface to minimap2, a fast and accurate C program to align genomic and transcribe nucleotide sequences
pkgver = 2.25
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/lh3/minimap2
arch = x86_64
license = MIT
makedepends = python-setuptools
makedepends = cython
- makedepends = zlib
makedepends = python-wheel
depends = python
depends = minimap2
+ depends = zlib
+ depends = glibc
options = !emptydirs
- source = https://github.com/lh3/minimap2/archive/refs/tags/v2.25.tar.gz
+ source = minimap2-2.25.tar.gz::https://github.com/lh3/minimap2/archive/refs/tags/v2.25.tar.gz
sha256sums = 9742ff0be01e51ea7d65f70c01d1344eee6f0d7b135359e0c00aec30fb74ac38
pkgname = python-mappy
diff --git a/PKGBUILD b/PKGBUILD
index 266101ac3ece..05303e53dda4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Bipin Kumar <kbipinkumar@pm.me>
pkgname=python-mappy
-_module=minimap2
+_source=minimap2
pkgver=2.25
-pkgrel=2
+pkgrel=4
pkgdesc="Python interface to minimap2, a fast and accurate C program to align genomic and transcribe nucleotide sequences"
arch=('x86_64')
url="https://github.com/lh3/minimap2"
@@ -11,30 +11,31 @@ license=('MIT')
depends=(
'python'
'minimap2'
+ 'zlib'
+ 'glibc'
)
makedepends=(
'python-setuptools'
'cython'
- 'zlib'
'python-wheel'
)
options=(!emptydirs)
-source=("https://github.com/lh3/minimap2/archive/refs/tags/v$pkgver.tar.gz")
+source=(${_source}-${pkgver}.tar.gz::https://github.com/lh3/minimap2/archive/refs/tags/v${pkgver}.tar.gz)
sha256sums=('9742ff0be01e51ea7d65f70c01d1344eee6f0d7b135359e0c00aec30fb74ac38')
prepare() {
- cd "$_module-$pkgver"
+ cd ${_source}-${pkgver}
sed -i 's|CFLAGS= -g -Wall -O2 -Wc++-compat #-Wextra|CFLAGS= -g -Wall -O2 -Wc++-compat -fPIC #-Wextra|g' Makefile
}
build() {
- cd "$_module-$pkgver"
+ cd ${_source}-${pkgver}
python setup.py build
}
package() {
- cd "$_module-$pkgver"
+ cd ${_source}-${pkgver}
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 "LICENSE.txt" -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 "LICENSE.txt" "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}