summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2020-12-20 12:52:11 -0500
committerAndrew O'Neill2020-12-20 12:52:11 -0500
commitad65b259b3be8d5bafc73f444f128b15081e4224 (patch)
tree2cb3565d0f2a8e934e081179ff618bf25a4610d9
parentdfe8816296d224f177e1922105aef8f9c2c7348a (diff)
downloadaur-ad65b259b3be8d5bafc73f444f128b15081e4224.tar.gz
Add fix for updating cython references to work with Python 3.9
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00ba2ea80d1a..53d9a497c9d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = python-marisa-trie
pkgdesc = Static memory-efficient & fast Trie-like structures for Python (based on marisa-trie C++ library)
pkgver = 0.7.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pytries/marisa-trie
arch = any
license = MIT
+ makedepends = cython
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
source = https://files.pythonhosted.org/packages/source/m/marisa-trie/marisa-trie-0.7.5.tar.gz
sha256sums = c73bc25d868e8c4ea7aa7f1e19892db07bba2463351269b05340ccfa06eb2baf
diff --git a/PKGBUILD b/PKGBUILD
index 786c89e57714..d0fae881c883 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,21 @@
pkgname=python-marisa-trie
_pyname=marisa-trie
pkgver=0.7.5
-pkgrel=1
+pkgrel=2
pkgdesc='Static memory-efficient & fast Trie-like structures for Python (based on marisa-trie C++ library)'
arch=('any')
url='https://github.com/pytries/marisa-trie'
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('cython' 'python-setuptools' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/m/${_pyname}/${_pyname}-${pkgver}.tar.gz")
sha256sums=('c73bc25d868e8c4ea7aa7f1e19892db07bba2463351269b05340ccfa06eb2baf')
build() {
cd ${_pyname}-${pkgver}
+ ./update_cpp.sh
+
python setup.py build
}